WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
Broke my admin site (8 posts)

4 stars
  1. simonysandra
    Member
    Posted 1 year ago #

    The plugin is great because of the various security options it offers. But suddently when I want to write a post or page the "visual/text" button has disappeared and qtranslate does not work either.

    I tried deactivating the plugin but nothing happened. So now I do not know what to do...

    Anyone got an idea how to fix it without undoing the new created files by BPS Security?

  2. AITpro
    Member
    Plugin Author

    Posted 1 year ago #


  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

  4. mjd1
    Member
    Posted 1 year ago #

    I had the same problem. Apparently WP 3.5 does not support having a .htaccess file (which is what BPS does).
    I fixed it by going into cPanel & deleting the .htaccess file (I think just the one in the root folder).
    Problem is, this now negates whatever hole it is that BPS is designed to plug... I found this post when searching to see if the conflict has been resolved, but apparently not. (looks like they are denying any problem related to BPS & the latest version of wordpress).
    I have delayed upgrading the rest of my wordpress sites in the hope that the conflict might have been fixed.
    I'm not at all techie.... I only discovered this by Google searching & laborious & tiresome fiddling.
    If anyone has a solution, I would like to know!

  5. mjd1
    Member
    Posted 1 year ago #

    BTW, deactivating the plugin won't do anything - in fact, you are supposed to deactivate & delete once it has done its job, which is to create the .htaccess file.
    It's the .htaccess file that is causing the problem.

  6. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    BPS .48 works perfectly fine with WP 3.5. There are no known issues, problems or conflicts. If you have a specific issue, problem or conflict on your particular website then please post your question here: http://wordpress.org/support/plugin/bulletproof-security.

  7. mjd1
    Member
    Posted 1 year ago #

    I wasn't trying to bag the plugin, just trying to find a solution.
    I did have a problem with BPS breaking WP 3.5, and I see that lots of others did as well, but it seems to be fixed now...thanks for all your work on this.

    I've just gone through & upgraded WP on all my sites to 3.5.1, and upgraded BPS as well to .48, no problems at all & very happy with the results at this point, & also to see that you've made some impressive upgrades in the plugin functionality.

    The original tutorial on WP security I followed, just used BPS for installing the .htaccess file, but I'm now reinstalling it on all my sites and will keep it upgraded & active.
    Also I'll take a trip to the BPS page to give it 5 stars - I know it must be a lot of work to keep up to date with all the changes with WordPress, & I appreciate this.

  8. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    Oh you had an older version of BPS. I totally missed that. Yep there was a problem with square brackets being blocked in WP 3.5 so we had to quickly change things (dump the square brackets filters) and get a new BPS version released ASAP - can you say SCRAMBLE MODE. LOL ;) Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.