WordPress.org

Ready to get started?Download WordPress

Forums

BulletProof Security
Breaks wordpress 3.5 (7 posts)

1 star
  1. railingcompany
    Member
    Posted 1 year ago #

    Breaks wordpress 3.5 and uninstalling does not remove all of the annoying code from the htaccess file. Wasted hours of work because of this extremely annoying feature

  2. bendelaney
    Member
    Posted 1 year ago #

    That is why you back up early and often. I never update WP on the first go-around to a new version. If my sites are working the risk-reward ratio is too high. But, anytime I add a new plugin, especially something that tampers with .htaccess file, it's important to get a clean, fresh backup of the database and files before doing anything. That way, if I break it, I can restore in just a few minutes.

    For a free plugin, BulletProof Security offers a tremendous value. But, you should never use something like this unless you are prepared for a glitch.

  3. AITpro
    Member
    Plugin Author

    Posted 1 year ago #

    @railingcompany - A new release of BPS was released within hours that fixed the issue.

    In our defense WP made a last minute coding change to WP 3.5 that we had not tested yet. We were prepared for the WP 3.5 upgrade months ago and were testing Nightly Builds of WP 3.5 up to 4 days before the release of WP 3.5, but that does not do much good when a last minute coding change is made. We were caught by surprise as well as some other plugin authors. These things happen in the coding World. You have to be prepared for anything and you have to move fast to change things - we did both things and the issue was resolved in hours.

    In the future just ask a question and you will get a very quick response from us. Thanks.

  4. PortMacOnline
    Member
    Posted 1 year ago #

    I can confirm that BPS DOES work fine with WP 3.5 and 3.5.1 - I have BPS running on well over a dozen websites with no problems, and all websites made it through the recent wave of hack attempts unscathed, even though all websites were inundated with failed attempts. If I could, I would rate the plugin 6/5!

  5. Marcel Oerlemans (Compass Creations)
    Member
    Posted 1 year ago #

    Great thing to read these responses and not just the first reaction! It's very understandable that these problems existed, and off course, always first backup! Still, there are many people that have great expierence with BPS, I don't have any, but will surely have some in the nereby future!

  6. PortMacOnline
    Member
    Posted 1 year ago #

    @Marcel, last night one of my websites was hit 62 times in a couple of hours in an obviously concerted attack, some of the hits were simultaneous, three of them in one second, but so far it has withstood everything that these losers have thrown at it with no problems at all.

    At the moment I am using the free version of Bulletproof Security along with the free version of Wordfence and they both 'play nice' together and between them they block just about every type of attack. But I will definitely be upgrading to the premium version of BPS this week on ALL my websites, both my own, and my client's, that is how impressed I am with BPS in particlular -- it hides the normally vulnerable files and folders that the hackers use to gain access through the 'back door', and Wordfence blocks the 'front door'.

    I highly recommend the combination, and can assure you that BPS does NOT "break WordPress"!

  7. cscottb
    Member
    Posted 1 year ago #

    Great advice PortMac! I was trying it with Better WP Security, but there are known conflicts with it. Wordfence sounds like a much more potent combo.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.