WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Breaks navigation menu? (5 posts)

  1. quantaweb
    Member
    Posted 4 months ago #

    I'm experiencing some difficulties with this plugin.

    It breaks my navigation. I'm using the FoxyNews theme from Themedy, it's a Genesis child theme. The navigation uses Superfish.

    When the page first loads, the drop-down navigation comletely expands, taking up much of the page. Here's a screen capture:

    https://www.dropbox.com/s/x8bs8ort8fni8i8/Screenshot%202014-03-31%2009.52.19.png

    Then, it goes away after a couple seconds and the navigation menu appears normally.

    Someone told me that the javascript minification was probably configured wrong but I don't know what to change to make it work. I experimented a bit and nothing changed.

    Someone else told advised me to turn off all minification completely but that kind of defeats the purpose of why I have W3 Total Cache installed, doesn't it?

    Any advice would be very welcome. I'm kind of freaking out because the site looks so terrible this way!

    Thanks for your help!
    all best,
    Denise

    https://wordpress.org/plugins/w3-total-cache/

  2. chucknb28409
    Member
    Posted 4 months ago #

    Hi,

    On the General Settings tab turn off Minify auto and set it to manual. Go to the Minify tab and then turn on each section one by one, making sure to delete all cache each time. That should help you narrow down what works and what does not. I have had no luck getting any .js files minimized in the header or body, so perhaps your theme will be different...

    Hope this helps some.

  3. chucknb28409
    Member
    Posted 4 months ago #

    Hi,

    I now actually have some js and css minified now. I also use superfish and it appears it can be safely added. In the minify tab click on the Help button near the top in the grey area to grab js and css files. Add a few at a time until something breaks.

    Hope that helps

  4. quantaweb
    Member
    Posted 4 months ago #

    Thanks for your help, Chuck. I deselected all javascript files in the minify area, intending to add them back in one by one, as you suggested. Then, I cleared the cache. But my navigation is still broken.

    I also don't know whether to select "combine only" or "minify" for "head", "after body" and "before /body".

    What with all the settings, and the various .js & .css files, there are hundreds of combinations...

    Funny thing is it was working perfectly last week...now it looks just terrible.

  5. quantaweb
    Member
    Posted 4 months ago #

    It's finally working...not quite sure what was wrong...I think perhaps it took a while for the cached versions of the page to clear. All is well. Thanks again.

Reply

You must log in to post.

About this Plugin

About this Topic