WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
[resolved] Breaking icons (20 posts)

  1. Ivdbroek
    Member
    Posted 5 months ago #

    Hi there!

    I got v 2.0.59 of NextGen Gallery and the Dante theme of Swiftideas.
    But the icons on my website are broken when NGG is activated.

    Nextgen activated: http://awesomescreenshot.com/0b92j4vbc9
    Nextgen deactivated: http://awesomescreenshot.com/0b52j4vc03

    Any idea how to fix or where the problem is?

    https://wordpress.org/plugins/nextgen-gallery/

  2. Ivdbroek
    Member
    Posted 5 months ago #

    webconsole throws this error, maybe it helps.

    downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:1): bad URI or cross-site access not allowed
    source: http://domain.nl/http://domain.nl/test/?ngg_serve_fontawesome_woff=1?v=4.0.3 test
    downloadable font: download failed (font-family: "FontAwesome" style:normal weight:normal stretch:normal src index:2): bad URI or cross-site access not allowed
    source: http://domain.nl/fonts/fontawesome-webfont.ttf?v=4.0.3

  3. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - My first thoughts are this may be server environment related, what details are shown under Gallery > Overview?

    - Cais.

  4. Ivdbroek
    Member
    Posted 5 months ago #

  5. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - Those settings seem like they should be fine, have you checked with your web host to see if there are any restrictions that may be in place that would see FontAwesome as a potential "cross-site access" issue?

    - Cais.

  6. Ivdbroek
    Member
    Posted 5 months ago #

    Besides adding mime types (which didnt help) they see no issues.
    the ngg addon code does use different urls:

    @font-face{
      font-family:'FontAwesome';
      src:url('../fonts/fontawesome-webfont.eot?v=4.0.3');
      src:
      url('../fonts/fontawesome-webfont.eot?#iefix&v=4.0.3')
          format('embedded-opentype'),
      url('../http://devalkeniers.nl/test/?ngg_serve_fontawesome_woff=1?v=4.0.3')
          format('woff'),
      url('../fonts/fontawesome-webfont.ttf?v=4.0.3')
          format('truetype'),
      url('../fonts/fontawesome-webfont.svg?v=4.0.3#fontawesomeregular')
          format('svg');

    source: http://devalkeniers.nl/test/?ngg_serve_fontawesome_css=1&ver=3.8.1

  7. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - This is what appears in our implementation:
    url('../fonts/fontawesome-webfont.woff?v=4.0.3') format('woff')
    ... where you are showing the full domain path being included above. I would think that needs to be sorted out.

    - Cais.

  8. Ivdbroek
    Member
    Posted 5 months ago #

    how do i solve this, since i did not alter the code in any way.
    I do have been looking around for the file to do some trial and error. but couldnt find it

  9. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - If your theme is also using FontAwesome you may be able to temporarily work-around this issue by finding and commenting out its implementation.

    I would suggest similar for NextGEN Gallery but that may be much more complicated.

    Have you contacted your theme author to see if they have any suggestions?

    - Cais.

  10. Ivdbroek
    Member
    Posted 5 months ago #

    yes i did at first, they said to go to you. so this is gonna be a vicious circle ;-)

    Could u point me towards disabling Fontawesome in NGG?
    Then ill contact Themeowner how i can disable it in them.

    Ill go then for the easiest way ;) (my preference is disabling it in NGG though)

  11. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - I stopped counting at 15 different instances that would have to be reviewed if disabled / commented out.

    Feel free to open the plugin in a good IDE and search for "fontawesome" ... we generally only enqueue it when needed but to be safe every instance should be reviewed before it is changed. This would also be over-written with the next update of the plugin which I would imagine will be a lot sooner than what your theme author is even considering so you would need to do all of the work over again if this particular conflict does not get sorted out.

    - Cais.

  12. Ivdbroek
    Member
    Posted 5 months ago #

    Apparently the probems is in server FA for IIS servers
    I out commented 1 line and it fixed the problem :)

    // Font Awesome
                if (wp_style_is('fontawesome', 'registered')) {
                    wp_enqueue_style('fontawesome');
                }
                elseif (strpos(strtolower($_SERVER['SERVER_SOFTWARE']), 'microsoft-iis') !== FALSE) {
    //              wp_enqueue_style('fontawesome', site_url('/?ngg_serve_fontawesome_css=1'));
                }
                else {
                    $router = C_Component_Registry::get_instance()->get_utility('I_Router');
                    wp_enqueue_style('fontawesome', $router->get_static_url('photocrati-nextgen_gallery_display#fontawesome/font-awesome.css'));
                }

    source: module.nextgen_gallery_display.php

  13. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - Thanks for the follow-up and your work-around. Please remember to check for this in future releases as you may need to re-modify this file for your installation.

    - Cais.

  14. Ivdbroek
    Member
    Posted 5 months ago #

    Thanks for the help and hope the code will get reviewed, since clearly it is not working as supposed.

  15. photocrati
    Member
    Plugin Author

    Posted 5 months ago #

    @Ivdbroek - Thanks. I have added this topic to our internal notes related to FontAwesome so our developers can add it to their review.

    ~Cais.

  16. bestspotsworld
    Member
    Posted 3 months ago #

    I have the same Problem on IIS on Windows Azure

    WordPress 3.8.3
    Photocrati NextGEN version 2.0.65, Photocrati NextGEN Pro version 1.0.17
    Site: http://www.bestspotsintheworld.com/fraser-island/

    I could not find the module.nextgen_gallery_display.php

    Thanks for your any suggestions.

    Daniel

  17. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @bestspotsworld - For any questions or concerns regarding NextGEN Pro please address them to our Support team via your member's area at http://nextgen-gallery.com/

    Thanks!

    - Cais.

  18. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    All - Just a quick note if you are using a Windows Azure server related to issues with FontAwesome issues, please have a look at this article: http://www.mattdurrant.com/windows-azure-gotchas/

    Thanks!

    - Cais.

  19. Ivdbroek
    Member
    Posted 3 months ago #

    @bestspotsworld the location of the file is:
    wp-content>plugins>nextgen-gallery>products>photcrati_nextgen>modules>nextgen_gallery_display

    i commented line 307

    hope it helps for you

  20. photocrati
    Member
    Plugin Author

    Posted 3 months ago #

    @Ivdbroek - Thanks for the suggested work-around.

    - Cais.

Reply

You must log in to post.

About this Plugin

About this Topic