WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] border only showing on top and left but not bottom and right side (4 posts)

  1. solucioneswebplus
    Member
    Posted 8 months ago #

    Strange thing happening here ... I recently changed to another WP theme and now suddenly the custom CSS which I have added is not working correctly anymore.

    Meaning, I want a solid 1px border around the whole table but in stead I only see the border on top and on the left but NOT on the bottom and right side of the table as you can see here http://bit.ly/18DNgEu

    I hebery place the code I have tried, also including to make widths to the table to see if that solves this issue but nothing is happening, no borders on the bottom and right side of table.

    .tablepress thead th,
    .tablepress tfoot th {
    	background-color: #A07E00;
    }
    
    .tablepress .odd td {
    	background-color: #FFFFFF;
    }
    
    .tablepress .even td {
    	background-color: #FFFFFF;
    }
    
    .tablepress .row-hover tr:hover td {
    	background-color: #A07E00;
    }
    
    .tablepress td,
    thead {
    	font-size: 11px;
    }
    
    .tablepress {
    	width: auto !important;
    	margin: 0 auto 1em;
    }
    
    .tablepress .column-1,
    .tablepress .column-2,
    .tablepress .column-3 {
    	width: 210px;
    }
    
    .tablepress,
    .tablepress tr,
    .tablepress tbody td,
    .tablepress thead th,
    .tablepress tfoot th {
    	border: 1px solid #DDDDDD;
    }

    Does anybody have a clue about what could be happening here ... I have tried hours to find a sollution reading all postst but .... nothing!

    Thanks.

    http://wordpress.org/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 8 months ago #

    Hi,

    thanks for your question, and sorry for the trouble.

    That's indeed really strange, and I also can not really see a reason why this is not working... My assumption that something is going on in the theme here...
    The only fix that I could find is a workaround with a background color for the table, that then emulates a border. Please try replacing

    .tablepress,
    .tablepress tr,
    .tablepress tbody td,
    .tablepress thead th,
    .tablepress tfoot th {
    	border: 1px solid #DDDDDD;
    }

    with

    .tablepress,
    .tablepress tr,
    .tablepress tbody td,
    .tablepress thead th,
    .tablepress tfoot th {
    	border: none;
    }
    .tablepress {
      background: #dddddd;
      border-collapse: separate;
      border-spacing: 1px;
    }

    Regards,
    Tobias

  3. solucioneswebplus
    Member
    Posted 8 months ago #

    GREAT !!!! that did the trick. I suppose it must be something in the themes code to mess things up but your fix workde for me. Great service Tobias, well done.

  4. TobiasBg
    Member
    Plugin Author

    Posted 8 months ago #

    Hi,

    no problem, you are very welcome! :-) Good to hear that this helped!

    Best wishes,
    Tobias

    P.S.: In case you haven't, please rate TablePress here in the plugin directory. Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.