WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce Moip
[resolved] Boleto's payment is COMPLETED in MoIP site but pendent in WooCommerce (11 posts)

  1. csfalcao
    Member
    Posted 9 months ago #

    Boleto's payment is OK in MoIP but pendent in WooCommerce.

    I created a product (virtual) and configured MoIP transparent checkout.
    I bought the product via boleto, then payed the boleto in a bank.
    In MoIP site the sale was there, and 2 days after paying the boleto, it says it's payed, the transaction is completed, but in WooCommerce the sale status is "pendent", like it hadn't being payed.
    I have not tested CC payment yet.

    http://wordpress.org/plugins/woocommerce-moip/

  2. csfalcao
    Member
    Posted 9 months ago #

    Ops, and thanks for the plugin, it´s really useful!

  3. Claudio Sanches
    Member
    Plugin Author

    Posted 9 months ago #

    Correctly set up following the installation guide:
    http://wordpress.org/plugins/woocommerce-moip/installation/
    You don't followed him!

  4. csfalcao
    Member
    Posted 9 months ago #

    Sorry man, I skipped the info about notifications in MoIP site. But now the things got worse: when I click the pay order, nothing happens. Another strange behavior is that when I choose CC it shows only the CC number and expiration date. then if I choose another kind of CC, another row of field shows up, with a third then another row belos. I don't know whats happening, I'll try to turn off w3 cage and cloud flare, then all the plugins, very strange...

  5. csfalcao
    Member
    Posted 9 months ago #

    ..w3 totalcache....

  6. csfalcao
    Member
    Posted 9 months ago #

    The cache and CDN is turned off, so the fields in checkout page are showing up correct now, but the "pay order" button dos nothing when I click it. All others buttons are ok, even the cancel order.

  7. csfalcao
    Member
    Posted 9 months ago #

    Hi Claudio,

    I´ve made some tests:
    Paypal is working (the default woo commerce plugin)
    Your MoIP payment is working in:
    XML mode, everything.
    Transparent mode, all but credit card. Boleto, transfer is OK.
    But transparent checkout and credit card the button"pagar pedido" do nothing, has no action. You click and it do nothing.

  8. Claudio Sanches
    Member
    Plugin Author

    Posted 9 months ago #

    Can probably be wrong in any given time to pay with card.
    This showing some notification saying this wrong the fields?

  9. csfalcao
    Member
    Posted 9 months ago #

    No error message. Paypal charged the same credit card, so no problem with it. Can we talk privately in portuguese (email, etc)? I can send you the log, or even a access to my site, I think it will be useful for the plugin if it´s a bug.

  10. Claudio Sanches
    Member
    Plugin Author

    Posted 9 months ago #

    Yes, you can send me an email at my website.

  11. csfalcao
    Member
    Posted 9 months ago #

    Sent an email

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.