WordPress.org

Ready to get started?Download WordPress

Forums

Body text display problem in Internet Explorer (15 posts)

  1. aasbd
    Member
    Posted 1 year ago #

    In the browser Internet Explorer the main body text do not show fully. But in firefox it is ok. The color also in IE shows different than firefox. I am not sure how to solve this problem. Any help from wordpress friends will be appreciated.

  2. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Unless you provide a link to a page demonstrating the problem, no one will be able to offer much in the way of assistance.

  3. aasbd
    Member
    Posted 1 year ago #

    Sorry, I forgot to add link of my site.

  4. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 1 year ago #

    :) Missing the link again

  5. aasbd
    Member
    Posted 1 year ago #

  6. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 1 year ago #

    Generally, the first step towards browser compatibility is validation.

  7. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  8. aasbd
    Member
    Posted 1 year ago #

    Thanks. After checking validation I have found 9 errors but I am not sure where can I put those code after using Clean up Markup with HTML-Tidy. Any help will be appreciated.

  9. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    That is not a good way to fix errors. Sorry, but you need to read the linked page.

  10. aasbd
    Member
    Posted 1 year ago #

    I got the following 8 errors. I am not sure how to correct those errors and where to put those corrected code in my child theme? I am looking for WordPress friend's help?

    Error Line 56, Column 62: Duplicate ID branding.

    <header id="branding" style="background-color: #FFFFFF ;">


    Warning Line 54, Column 37: The first occurrence of ID branding was here.

    <header id="branding" role="banner">


    Error Line 56, Column 62: Element header not allowed as child of element hgroup in this context. (Suppressing further errors from this subtree.)

    <header id="branding" style="background-color: #FFFFFF ;">

    Contexts in which element header may be used:
    Where flow content is expected.
    Content model for element hgroup:
    One or more h1, h2, h3, h4, h5, and/or h6 elements.

    Error Line 56, Column 62: The element header must not appear as a descendant of the header element.

    <header id="branding" style="background-color: #FFFFFF ;">


    Error Line 58, Column 24: Heading cannot be a child of another heading.

    <h1 id="site-title"><span><a href="http://www.aas-bd.com/" title="ADVANCED …


    Error Line 60, Column 12: End tag hgroup seen, but there were open elements.

    </hgroup>


    Error Line 56, Column 62: Unclosed element header.

    <header id="branding" style="background-color: #FFFFFF ;">


    Error Line 60, Column 12: Element hgroup is missing a required instance of one or more of the following child elements: h1, h2, h3, h4, h5, h6.

    </hgroup>

    Content model for element hgroup:
    One or more h1, h2, h3, h4, h5, and/or h6 elements.

    Error Line 166, Column 88: The align attribute on the div element is obsolete. Use CSS instead.

    …addfreestats-wordpress" STYLE="position:relative;bottom:120px;" align="center">


    Warning Line 183, Column 106: The border attribute is obsolete. Consider specifying img { border: 0; } in CSS instead.

    …nnect.cgi?usr=00352401Pauto" border=0 alt="AddFreeStats">Website Statistics

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Most of those are likely in your header.php file. If you copy that file to a pastebin, I'll see if I can help you sort them out.

    See this re: using pastebin:

    http://codex.wordpress.org/Forum_Welcome#Posting_Code

  12. aasbd
    Member
    Posted 1 year ago #

    Please check the link: http://pastebin.com/j9q521BA

  13. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    It looks like you need to remove these two lines from the header.php file -- they are not doing anything anyway:

    <header id="branding" style="background-color:  #FFFFFF ;">
    <h2 id="header-description" style="background-color:#FFA500;">

    You might need to make a CSS adjustment after removing them, but post back after you've removed them and I'll look at that.

    Then let's see what errors are still there.

  14. aasbd
    Member
    Posted 1 year ago #

    I have removed the codes you suggested both from the header.php and style.php. Now the header almost looks like nice except color. But the body texts are not seen fully from left. And right side bar also gone down from main body content. All these problems are in IE Browser only. In the Firefox all are OK.

  15. Andrew Nevins
    Spam zapper & Volunteer Moderator
    Posted 1 year ago #

    For CSS-specific queries, consider CSS-specific forums.

Topic Closed

This topic has been closed to new replies.

About this Topic