WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] blurry photos in twenty eleven child theme (5 posts)

  1. lala100
    Member
    Posted 1 year ago #

    Wasn't sure where to post this, but here goes:

    The photos that I insert into my posts are blurry. How do I solve this?

    I posted in this forum because I've been building a twenty eleven child theme and I've altered my style.css file a lot. I wasn't sure if this was an issue that I created by changing my style sheet, or if it could be solved by further altering my style sheet.

    http://www.GrimmAles.com

    Any help would be great.
    Thanks!

  2. paulwpxp
    Font hero
    Posted 1 year ago #

    Right now that image is 300px scaled up to the max width of your conent which is around 500px. Usually it won't get that blurry, but in this case, your original uploaded image is VERY big, so it's downsized to 300px and losed its clarity already.

    Set a proper size of image when placing <img> tag into post.
    http://codex.wordpress.org/Inserting_Images_into_Posts_and_Pages

    Default sizes ( cropped upon upload ) can be set.
    http://codex.wordpress.org/Settings_Media_Screen

    If settings on sizes changed, it won't effect images already uploaded, WP crops image upon upload only, use a plugin called "Regenerate Thumbnails" to resize them all when these settings changed.

  3. lala100
    Member
    Posted 1 year ago #

    Thank you!!!!! Problem fixed :)

  4. paulwpxp
    Font hero
    Posted 1 year ago #

    Not really.

    Right now you have this:

    <img class="aligncenter size-full wp-image-236" alt="fromthehip" src="http://example.com/wp-content/uploads/2013/05/fromthehip4.jpg" width="3204" height="2316" />

    Notice these classes:
    size-full and width="3204" height="2316"

    When done right, see first link in my first post, it should be:
    size-large or size-medium with the w and h as set in media settings.

    The "full" is too big in this case because your original uploaded image is VERY big, browser loads that big image just to be viewed in 500px width column.

    This is wasting bandwidth.

    To wrap it up in a few words, when inserting <img> into post content check on "medium" or "large", not "full".

  5. lala100
    Member
    Posted 1 year ago #

    Ok. Thanks for the follow-up. I think that it's fixed now!

Topic Closed

This topic has been closed to new replies.

About this Topic