WordPress.org

Ready to get started?Download WordPress

Forums

Blogs with www.mysite.com vs. http://mysite.com PROBLEM! (5 posts)

  1. kenfused
    Member
    Posted 9 years ago #

    Hello,
    I have my permalink structure as /%postname%.htm
    and wordpress address as:

    http://www.mysite.com/blog

    I have the blog on http://www.mysite.com and http://www.mysite.com/blog,

    WHen I go to http://www.mysite.com or http://www.mysite.com/blog I get "SORRY NO POSTS MATCHED YOUR CRITERIA), but if I go to
    http://mysite.com or http://mysite.com/blog
    EVERYTHING WORKS!

    What happened!?

  2. skeltoac
    Member
    Posted 9 years ago #

    Why the .htm extension?

  3. kenfused
    Member
    Posted 9 years ago #

    Someone suggested using it... for Search engines...

  4. skeltoac
    Member
    Posted 9 years ago #

    Whatev. You have your blog in /blog right? How are the URLs set up in wp-admin Options? Is your httpd.conf treating mysite.com and http://www.mysite.com differently?

    Would you mind removing the www. from your URL forever?

  5. Using .htm as part of your permalinks will do nothing for search engines. That's an old myth that died about three years ago. To learn more about search engine optimization and WordPress, see: http://codex.wordpress.org/Search_Engine_Optimization_for_Wordpress

    To fix your problem, please tell us what URLs you have entered in Options/General.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.