WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blogroll error after upgrade to 2.2.1 (3 posts)

  1. daitya
    Member
    Posted 7 years ago #

    Yikes! My blogroll disappeared. Everything else seems okay with the upgrade, but I have no idea what to do about my missing blogroll links. The links are all there under the "Blogroll Management" tab, but on the home page the following message appears where the blogroll ought to:

    WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1]
    SELECT cat_id, cat_name FROM

    Blog url: http://www.hansadutta.com/KRSNA_WORLD/
    Theme: Connections Reloaded
    Upgraded with Fantastico
    PHP version 4.4.4
    MySQL v 4.1.21-standard
    Apache 1.3.47 Unix

    Yes, did the backup thingy with phpMyAdmin & saved all files to my computer, then upgraded, and went into wp-config.php and deleted the 2 troublemaker lines DB_CHARSET and DB_COLLATE. As mentioned above, everything else seems to be working.

    I hope someone will be patient to guide me thru any fix step by step, because I am no techie and I dunno nuthin about MySQL or Shell commands (a spoiled Mac user). Just looking at the instructions for manually upgrading scares the bejeebers out of me.

    Thanks in advance--Daitya

  2. daitya
    Member
    Posted 7 years ago #

    The blogroll uses the following code in the sidebar.php for this theme (Connections Reloaded). Could it be that something in this code is incompatible with the upgrade (2.2.1)?

    <?php /* If this homepage */ if (is_home()) { ?>
    <h2><?php _e('Links'); ?></h2>
    <ul>
     <?php
     $link_cats = $wpdb->get_results("SELECT cat_id, cat_name FROM $wpdb->linkcategories");
     foreach ($link_cats as $link_cat) {
     ?>
      <li id="linkcat-<?php echo $link_cat->cat_id; ?>"><h3><?php echo $link_cat->cat_name; ?></h3>
       <ul>
        <?php wp_get_links($link_cat->cat_id); ?>
       </ul>
      </li>
     <?php } ?>
    </ul>
       <?php } ?>

    Is the theme the problem, or is it a database error in the upgrade? Please help.

  3. daitya
    Member
    Posted 7 years ago #

    I have since contacted AjayDSouza at his Connections Reloaded Support Forum (http://ajaydsouza.org/index.php/board,4.0.html), and he suggested I switch themes to see whether the problem persists. I did so, and the blogroll now appears normally. At least now it has been confirmed that the problem is not due to an upgrade failure. I suppose this means that WordPress v.2.2.1 breaks Connections Reloaded v.1.2.2. Let's see whether AjayDSouza will be able to detect the buggy code and come up with a fix. In the meantime, I think we can close this topic here on WordPress, as it really is a matter for the theme author to resolve.--daitya

Topic Closed

This topic has been closed to new replies.

About this Topic