WordPress.org

Ready to get started?Download WordPress

Forums

Bloglines' blogroll function (14 posts)

  1. Kathy_P
    Member
    Posted 9 years ago #

    Has anyone successfully used Bloglines' blogroll function in a WP 1.5 installation? I tried to paste the javascript code into sidebar.php and it shows up in Firefox and Opera but not IE. (If you have a Bloglines account, click on the Share tab and the instructions for generating the html code are there.)

  2. davincim
    Member
    Posted 9 years ago #

    I couldn't even get it to work in Firefox. I'll be keeping an eye on this thread. Thanks for posting. :)

  3. I had no luck either. Under Wp v1.2, I just linked to my blogroll over at Bloglines. When WP v1.5 came out, I used the Pages features to post my blogroll. In the end, it's easier to keep your own and not rely on 3rd party services.

  4. davincim
    Member
    Posted 9 years ago #

    @macmanx - Oh yeah, I remember yours now. Nice and clean. Good advice. :)

  5. Thanks for the compliment.

  6. Kathy_P
    Member
    Posted 9 years ago #

    "In the end, it's easier to keep your own and not rely on 3rd party services" If all's you're doing is keeping a blogroll, the links management in WordPress is great, and I agree, it's best not to rely on third party services. But by using the Bloglines blogroll on my current MT blog, I've been able to do 2 things with one copy-and-paste: 1) add a feed to my Bloglines account, and 2) add the same to my blogroll. Before I used the Bloglines blogroll, I would often do #1 and forget to do #2.

    What really puzzles me is why it won't work with IE in WordPress when it did work with IE before. I merely commented out the Blogroll list that was in sidebar.php before inserting the Bloglines code. Is IE picky about commenting out? Look at this page in Firefox and IE--do you see a difference? http://www.coldclimategardening.com/index.php

  7. ankaisa
    Member
    Posted 9 years ago #

    I just added my blogroll and it seems to be working just fine. So I can't say why yours does not show up in IE - I cliked on the link and it did not. Mine works also in IE. I do not know if different themes produce different results, as I seem to be using a different one.

  8. ankaisa
    Member
    Posted 9 years ago #

    Sorry, can't seem to be abole to edit the previous post... For some reason my site is not co-operating at the moment, so you can't really see my blogroll but it did work an hour ago. I'll see if I can figure out why it is not responding

  9. Kathy_P
    Member
    Posted 9 years ago #

    When you configured your Bloglines blogroll, did you specify target=_blank? I did, and I think that is part of the problem. Also, some of the commenting I did was not closed correctly. I ran my blog through the xml validator and I'm still fixing the problems. After I fix all the problems and take out the target=_blank, I'll report back. It may just be these errors that keep IE from rendering it.

  10. Kathy_P
    Member
    Posted 9 years ago #

    When you configured your Bloglines blogroll, did you specify target=_blank? I did, and I think that is part of the problem. Also, some of the commenting I did was not closed correctly. I ran my blog through the xml validator and I'm still fixing the problems. After I fix all the problems and take out the target=_blank, I'll report back. It may just be these errors that keep IE from rendering it.

  11. Kathy_P
    Member
    Posted 9 years ago #

    When you configured your Bloglines blogroll, did you specify target=_blank? I did, and I think that is part of the problem. Also, some of the commenting I did was not closed correctly. I ran my blog through the xml validator and I'm still fixing the problems. After I fix all the problems and take out the target=_blank, I'll report back. It may just be these errors that keep IE from rendering it.

  12. ankaisa
    Member
    Posted 9 years ago #

    Ah, the site seems to be working just fine form home! Maybe it was just the connection. And yes, all links have target=_blank, so that should not be it. I can link to my sidebar.php if you want to take a look at it. The site is http://ankaisa.host.sk/blog/ if you want to try it. I can't guarantee it works at any given time, but it works for me right now!

  13. Kathy_P
    Member
    Posted 9 years ago #

    Ankaisa, I see that yours works. Did you comment things out, or delete them? Or did you just squeeze the bloglines code in? And I am sorry for the duplicate posts, but I can't edit them out, either.

  14. ankaisa
    Member
    Posted 9 years ago #

    What I really did was I looked at the code to see how the other links were done and copied that(multiple times as you can see). Then I threw away what was inside the tags and inserted the Javascript code from Bloglines. I can't explain it any better, but if you want to see my sidebar.php email me at ankaisa@yahoo.com and I'll email it to you!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags