WordPress.org

Ready to get started?Download WordPress

Forums

Blogger imported/new posts not showing/theme issue? (22 posts)

  1. bethabristol
    Member
    Posted 4 years ago #

    I installed wordpress through my host, I imported all my blogger content and that is all that is showing up. I have written and publised two new posts in wordpress and they say that they are published but they are not showing up.

    I tried going into each post and removing the blogger related custom fields but that did not fix it.

    I have enable both Atom and XML publishing but that didn't fix it.

    I had the support people at my host look into it for me (because no one was responding to my previous post here) and they said it was an issue with the themes and that I would have to debug on my end.

    I have no idea what the problem with the themes could be.

    Can anyone help?

  2. If you can post a link to your blog, it may be a little bit easier to investigate the cause.

  3. bethabristol
    Member
    Posted 4 years ago #

    Update: I was able to get them to publish to their own pages by chagning which permalink format I used, but I still haven't been able to get them to show on the home page (which is http://www.famousfanmail.com).

    Searching through the forums I've found someone having a similar problem and the responses seemed to indicate that the issue was in the index.php file of the theme, but not precisely what/where in the index.php file.

  4. I see a Blogger blog at the linked page, not a WordPress blog.

  5. bethabristol
    Member
    Posted 4 years ago #

    That's exactly the problem. I've installed wordpress on my host and imported all of the content from blogger. The individual posts from wordpress show from their permalinks now but not on the home page. The home page is still showing only the old stuff.

    (http://famousfanmail.com/2010/05/08/seattle/)

    Tech support at my hosting provider said that the issue is with my wordpress themes but they couldn't identify for me what the issues is with my wordpress themes. I tried changing to a different theme but that didn't help.

  6. Oh, I'm sorry! Slight misunderstanding.

    The Good News:

    That's an easy fix!

    Go to your root directory (probably /public_html/) either with an FTP client or the file manager in your hosting provider's control panel and delete the index.html file.

    The Bad News:

    You hosting provider should have known better than that. Shame on them. Conflicting indexes is part of web hosting 101.

  7. bethabristol
    Member
    Posted 4 years ago #

    I did that but now there's nothing on the home page.

  8. bethabristol
    Member
    Posted 4 years ago #

    I deleted it from the root directory. Should I delete index.php too?

  9. bethabristol
    Member
    Posted 4 years ago #

    Or should I delete Home.html?

  10. No, don't delete index.php. You could delete Home.html, but it won't be necessary. index.html is still there. You may be in the wrong directory. You want to be in the same directory as the wp-rss2.php file. Once you have found that file, delete the index.html file from that directory.

    Some control panel file managers are buggy, so if you're using one, you may need to use an FTP client instead.

  11. bethabristol
    Member
    Posted 4 years ago #

    I'm reluctant to go the FTP client option because...and I'm remarkably unsavvy about this, but wouldn't the FTP client option mean that I could only publish from the computer I had the FTP client downloaded on?

  12. No, an FTP client is just another way to browse, upload, download, delete, and modify files. It's usually more reliable than a control panel's file manager.

    If you're on a PC, try FileZilla and follow this guide.

    If you're on a Mac, try Cyberduck and follow this guide.

  13. bethabristol
    Member
    Posted 4 years ago #

    I'm very confused. When it say's

    It's fast, stable, easy to use, and free. FTP is a standard way to upload or download files between your local system and your web server

    Doesn't "your local system" refer to the PC that you've downloaded the FileZilla software on. Meaning that I would have to be using that PC (or another one that has FileZilla on it) in order to upload files to my server?

  14. Yes, it's an application, so you would have to install it on your PC in order to use it.

  15. bethabristol
    Member
    Posted 4 years ago #

    So, if I want to be able to use any PC to upload files then I have to use my host's file manager. What if I unintsall wordpress, completely delete the root directory and then re-install wordpress? Would that potentially solve the problem?

  16. No, just use the FTP client, FileZilla. Install it on your computer, follow this guide, navigate to your root directory (probably "public_html"), and delete the index.html file.

    If you need more help with FileZilla, you can refer to their documentation.

  17. bethabristol
    Member
    Posted 4 years ago #

    Well, the computer I'm currently using I cannot download software to. In fact I'm often at public computers that I'm not allowed to download software to. I'm so rarely at my computer at home, and my laptop is currently out of commission, so downloading software is not a feasible option for me. I'm going to try unistalling wordpress, deleting the entire public_html folder, then reinstalling wordpress and see if that works.

  18. Alternatively you could ask your hosting provider to delete the file for you. The worst they could do would be to say "no".

  19. bethabristol
    Member
    Posted 4 years ago #

    It worked.

  20. bethabristol
    Member
    Posted 4 years ago #

    It's moot now, but I did ask them and they said they didn't see the file in the folder anymore either. I had already deleted it, I don't know how or where it still existed because it definitely wasn't in the public_html folder anymore.

    Anyhow, the uninstall/delete public_html/reinstall worked...and luckily I remembered to copy and paste the new posts into the notepad before I did it so I didn't loose any content.

    Thanks for all the help. I was totally at a loss.

  21. You're welcome! I'm glad it worked out in the end.

Topic Closed

This topic has been closed to new replies.

About this Topic