WordPress.org

Ready to get started?Download WordPress

Forums

Blog virtual directory (4 posts)

  1. pmorim217
    Member
    Posted 2 years ago #

    I am trying to get my blog to appear - we are using a custom theme based off 2011. I changed the front page displays in my settings:read, but it is not working. My site is http://www.newitpartners.com, the blog should be at . http://www.newitpartners.com/tektipsI can't seem to get any of my blog postings to show.

  2. peter achutha
    Member
    Posted 2 years ago #

    1. Did you install WP in http://www.newitpartners.com or in http://www.newitpartners.com/tektips ?

    2. When you login and go to your control panel under Settings>>General what is set in these fields WordPress Address (URL) & Site Address (URL)?

    3. Are you using a static homepage?

  3. pmorim217
    Member
    Posted 2 years ago #

    WP was installed in http://www.newitpartners.com, both addresses are http://www.newitpartners.com, and yes I am using a static home page. And oh no, I just broke my site. I tried putting http://www.newitpartners.com/tektips in the WordPress address URL and now I'm getting nothing found.

  4. peter achutha
    Member
    Posted 2 years ago #

    Ok there is a way out of this problem ... actually two ways.

    1. Do you know where your theme folder is? (This is the way I prefer but it is a long winded method). What is your theme? Go to your theme folder and edit functions.php . Just after <?php right at the beginning put these two lines of code:-

    update_option('siteurl','http://www.newitpartners.com');
    update_option('home','http://www.newitpartners.com');

    Then login into your site and go to Settings > General and just check that WordPress Address (URL) & Site Address (URL) are set to http://www.newitpartners.com. It should be set to that value. Click on save button. Logout and then log back in and save again. Do this a few times. View your site and it should be back to normal. Once everything is back to normal delete those two lines of code in the functions.php file. And check your site log in and view site. It should be restored.

    2. The second method is to hardcode the URL's. Go to your WP root level and find wp-config.php and edit the file. Right at the top just after <?php add the folloing two lines of code:-

    define('WP_HOME','http://www.newitpartners.com');
    define('WP_SITEURL','http://www.newitpartners.com');

    save the file and load up your site and login. Your site will be back but if you go to Settings >> General you will find you cannot change the WP Add and Site URL as it is hardcoded in. This method is good if you have some serious problems with your site.

    The first method will get your site up as if nothing happened and that is the advantage of the first method.

    See http://codex.wordpress.org/Changing_The_Site_URL for more explanation.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.