WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blog sites transfered to another server -> subsites not found anymore (5 posts)

  1. Pirjo
    Member
    Posted 7 months ago #

    I have transfered our WordPress 3.3.1. multiuser blogs to another server and on a new domainname.

    The blog sites are on directory structure:
    bootthrowing.net/blog/admin
    bootthrowing.net/blog/isokojar
    ...

    When you try to go to subdirectories you get the error message below
    "Not Found
    The requested document was not found on this server."

    To the main page (bootthrowing.net/blog/) you are able to go, but you get it without pictures.

    I have changed all old domainnames to new ones on the database and on scripts. At least I think so.

    Can you help me and tell what I have to do to fix this problem.

    Br. Pirjo

  2. harmonyinfotech
    Member
    Posted 7 months ago #

    Try flushing the permalinks. You can just select different option, revert back to original one and save it to flush them and rewritten to .htaccess. Also make sure there is .htaccess in root folder.

  3. Pirjo
    Member
    Posted 7 months ago #

    Hi,

    Thank you for your answer.

    I tried you asked me to do. But it didn't help. My .htaccess is on the bootthrowing.net/blog/ -dicectory as it was on the old server. It is this kind:

    # BEGIN WordPress
    RewriteEngine On
    RewriteBase /blog
    RewriteRule ^index\.php$ - [L]
    
    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(wp-(content|admin|includes).*) $1 [L]
    RewriteRule ^[_0-9a-zA-Z-]+/(.*\.php)$ $1 [L]
    RewriteRule . index.php [L]
    # END WordPress

    Br. Pirjo

  4. The images are pointing here:

    http://bootthrowing.net/blog/files/heittajienklubilinkki.jpg

    Which translates to this:

    http://bootthrowing.net/blog/wp-includes/ms-files.php?file=/heittajienklubilinkki.jpg

    So that works, and it means that your new server doesn't like the complex .htaccess rules. Ask your webhost if httpd.conf has AllowOverride set to either All or Options All

  5. Pirjo
    Member
    Posted 7 months ago #

    Hi,

    Thank you for your advises. The problem is solved now. AllowOverride is ok on our new server. Today I noticed that .htaccess file's name was changed when I transfered the files to the new server. It was after transfering htaccess. After I saved it on notepad inside apostrophes (".htaccess") I got the dot back.

    Br. Pirjo

Reply

You must log in to post.

About this Topic

Tags

No tags yet.