WordPress.org

Ready to get started?Download WordPress

Forums

Blog reverts to Default - Event Log to Figure Out Problem? (6 posts)

  1. missadventures
    Member
    Posted 4 years ago #

    Hi there,

    I'm having problems with my blog (www.italofile.com) reverting to the default theme. I've had the blog for almost 3 years, but this only started happening around mid-June. Now after I change the theme back it only sticks for a day or so.

    Is there any way that I can see an event log to see when the default theme was triggered? I was using WP 2.7 when the revert started happening, but had had 2.7 installed for a good several months before it started happening. I'm thinking there's a plugin problem but don't want to deactivate one by one to figure it all out (I've got a lot and the look of my blog would change).

    Couple of background pieces of info. I have upgraded to 2.8.1 - no problems, except theme is continuing to revert. Also, I looked to see if there was an old version of this blog on my server that was being accidentally called up but could not find any such thing.

    If anyone can help, that'd be swell.

    Thanks!
    Mel

  2. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Either there's a problem in your theme or you have a plugin problem. You could try looking for any error.log files on your server but you may still have problems figuring out what exactly is causing the problem. The only way to troubleshoot this properly is to:

    1. Deactivate all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    2. Switch to the default theme to rule out any theme-related problems.

    Yes - you feel that each and every one of your installed plugins is vital and your blog cannot possibly use another theme but what do you want? All of those plugins and that theme? Or a blog that manages to keep it's theme for more than 2 days at a time?

  3. missadventures
    Member
    Posted 4 years ago #

    Ah...some tough love and sound advice from esmi. I'll give it a try!

  4. missadventures
    Member
    Posted 4 years ago #

    Okay...so I deactivated all plugins and reactivated them one by one, making sure to Ctrl+F5 between each one to see if there was a problem. No problem at all...YESTERDAY.

    I log on this morning and the theme has reverted to default. Sooooo, I'm guessing it's a theme problem?

    The only problem with that line of thinking is that the theme was working fine previously. It was not the install of version 2.8.1 that did it either, as I was having this revert problem before then.

    Ugggh...any other advice? Anyone?

    Thanks!

  5. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    Try another theme and monitor the blog for a few days. If it's stable, then it's a confirmed theme issue. What the exact problem is is pretty much anyone's guess at this point.

  6. missadventures
    Member
    Posted 4 years ago #

    I think I found the problem!

    I thought I had a theme issue b/c I changed back to an old theme that was working...up to today.

    When I went to login today, I got the message that I needed to upgrade my database (new autofeature of WP 2.8.x?). I upgraded then went to look at my site and - YEP! - it had reverted to default.

    So, this is definitely a database issue. But I guess it could also be a theme and/or plugin issue because the upgrading is triggering some unknown code, right? Very annoying.

    If anyone can help, please please please!

Topic Closed

This topic has been closed to new replies.

About this Topic