WordPress.org

Ready to get started?Download WordPress

Forums

BlackBird
[resolved] Blog posts - receiving an error when clicking on them directly (19 posts)

  1. alisonthewordsmith
    Member
    Posted 11 months ago #

    I was able to get my blog page to show posts, no problem. But when i click to read the full post, i get an error. This happens every time and I need to know how to fix it. Any help would be greatly appreciated. I'm using the free version of blackbird.

    my site is eventsbyvoila.com.

  2. James Richman UK
    Member
    Posted 11 months ago #

    Hi Alison ;)

    By the look of it, this could be a permalink issue.
    Could you please tell me did everything work fine at the beginning?

    And when did you start to get this error?
    Did you install or change anything?

    Cheers
    James Richman

  3. alisonthewordsmith
    Member
    Posted 11 months ago #

    Hi James. thanks for getting back to me.

    This error started today when i created the blog page and posted to it for the first time. I have installed two plugins, but i uninstalled them and it still didn't work. I have added a bit of custom css to the site to change a few visual things (colors, etc) but i don't imagine that would affect this.

    HOWEVER... i did mess around with custom naming all the permalinks for appearances.. would that affect it?

  4. James Richman UK
    Member
    Posted 11 months ago #

    Yup Alison,
    Permalinks settings look easy, but sometimes a small change can cause a site to break down.

    Is there a way I could see your permalinks settings, or get to actually see your wp backend?

  5. alisonthewordsmith
    Member
    Posted 11 months ago #

    That did it!

    I went in and changed my permalink settings back to default and now the post is showing up just fine.

    Thanks for all of your help today.

  6. alisonthewordsmith
    Member
    Posted 11 months ago #

    resolved!

  7. James Richman UK
    Member
    Posted 11 months ago #

    Yup, I can see it works now :)

    Only one advise tough:
    You don't have to stick to that ugly url "?p=352", to make sure your site works again.

    It's better if you set your permalinks to have a "pretty" url instead.
    Something like "5-best-wedding-venues"

    Not only will it look good for your website visitors, but it's also really crucial for SEO.

    So if set up properly you can have both: pretty urls + working site.

    Thought I couldn't let you go without making sure you are aware of it.

  8. alisonthewordsmith
    Member
    Posted 11 months ago #

    How do i set it up to do that? If i just changed everything from the custom links, wouldn't it just revert back to not working properly if i change it back?

  9. James Richman UK
    Member
    Posted 11 months ago #

    Which permalinks settings option did you have selected?

  10. alisonthewordsmith
    Member
    Posted 11 months ago #

    "custom structure"

  11. James Richman UK
    Member
    Posted 11 months ago #

    And what did you have written in that field?

  12. alisonthewordsmith
    Member
    Posted 11 months ago #

    either "voila" or "/voila"

  13. James Richman UK
    Member
    Posted 11 months ago #

    That's the problem.
    Go back and select "Post name" option.

    And try again please ;)

  14. alisonthewordsmith
    Member
    Posted 11 months ago #

    That worked! you were super helpful! thanks a ton.

  15. James Richman UK
    Member
    Posted 11 months ago #

    Glad to hear that Alison ;)
    It was my pleasure.

    One last advice:
    In the future when you write new posts, you don't have to stick to a url that will be given by WordPress.

    You can easily change it yourself.
    Here's a screenshot of where exactly you can change it.

    So instead of having "welcome" you can change it to "welcome-to-voila".

    All The Best
    James Richman

  16. Paulinho121
    Member
    Posted 11 months ago #

    Hi James.

    I am suffering the same problem and resetting to default permalinks resolves the problem, but they are ugly. I go back to post name option and the problem comes back - when you select the blog it shows the broken link message.

    Don't have many plugins - just seo yoast, w3 total cache and google analytics for wp.

  17. trishna
    Member
    Posted 8 months ago #

    Hi Alison,
    I am building a website also using the free version of Blackbird. I am having trouble setting the blog page to show posts. Could you please help me with this as you have been able to do this successfully? Thank You.

  18. esmi
    Theme Diva & Forum Moderator
    Posted 8 months ago #

    @trishna: As per the Forum Welcome, please post your own topic.

  19. trishna
    Member
    Posted 8 months ago #

    Okay, I just did that. Sorry for the inconvenience.

Reply

You must log in to post.

About this Theme

About this Topic