WordPress.org

Ready to get started?Download WordPress

Forums

Blog posts are showing up fully on home page, instead of summarized. (10 posts)

  1. Vel252
    Member
    Posted 1 year ago #

    On my blog home page, it shows the most recent postings, which is what I want. However it shows the posts in their entirety, which is not my goal.

    I'd like to have the main page show the most recent 10 or so posts I have made. But only showing the introduction of each post, where the reader would have to click on the post title to read the full post.

    My page is currently showing the most recent 3 posts I have made, and my main page is probably 15 pages in length - looks pretty tacky.

    I've gone to Dashboard -> Settings -> Reading and changed the 'For each article in feed, show...' From "Full Text" to "Summary" but it didn't change what shows up on the main page.

    Any help would be appreciated, thanks!

  2. ak.singla
    Member
    Posted 1 year ago #

    It depends upon the theme. Which theme are you using??

  3. Vel252
    Member
    Posted 1 year ago #

    Coogee version 0.2.2

  4. ak.singla
    Member
    Posted 1 year ago #

    You may try searching index.php file for ::

    the_content();

    and replace it with :

    the_excerpt();

  5. Vel252
    Member
    Posted 1 year ago #

    Where would I find the index.php file?

    Sorry, I've only been using WordPress for a day. >.<

  6. ak.singla
    Member
    Posted 1 year ago #

    In your hosting control panel,
    wp-content >> themes >> coogee(themenamedirectory) >> index.php

  7. Vel252
    Member
    Posted 1 year ago #

    I couldn't figure it out so hopped in live chat with my host and they followed your directions and made it happen! Thanks!

  8. Vel252
    Member
    Posted 1 year ago #

    Eh, scratch that. I wasn't able to click on the post and see the full version.

    I think I'll deal with it for awhile until I gain more experience with all this. =P

    Thank you though!

  9. ak.singla
    Member
    Posted 1 year ago #

    Try adding this after the first "" ?> "" after the_excerpt(); statement.

    <a href="<?php the_permalink(); ?>" title="Continue Reading">Read article</a>
  10. Vel252
    Member
    Posted 1 year ago #

    Didn't work either.

    Think I might talk to a friend of a friend and see if he'll be willing to do it for a few bucks. This coding thing gives me a headache. lol

    Thanks for your time though, I appreciate it!

Topic Closed

This topic has been closed to new replies.

About this Topic