WordPress.org

Ready to get started?Download WordPress

Forums

Travelify
[resolved] Blog Post Template (11 posts)

  1. viclops
    Member
    Posted 11 months ago #

    I want my blog page to show my entire blog posts. I've tried setting the page template to Blog Full Content Display, but posts still show excerpts only. When I changed the page template to Blog Image Large and previewed before updating, it shows my posts in their entirety. But when I update, it changes back to excerpts.

  2. mybdbis
    Member
    Posted 11 months ago #

    Please post the link of your page

  3. viclops
    Member
    Posted 11 months ago #

    victorialopes.com/blog

  4. mybdbis
    Member
    Posted 11 months ago #

    Please Replace <?php the_excerpt(); ?> with <?php the_content(); ?> in blog page loop for more information about wordpress loop.. Please visit The Loop

  5. esmi
    Forum Moderator
    Posted 11 months ago #

    No! Do not edit the theme itself! First create a child theme for your changes.

  6. mybdbis
    Member
    Posted 11 months ago #

    Yes exactly. Thanks esmi, forgot to quote that.

  7. Silkalns
    Member
    Theme Author

    Posted 11 months ago #

    Thanks esmi and mybdbis for quick responses!

    Viclops,
    I inspected your source code and I can clearly see that you are not using any of my theme templates. You are using the default one.

    When editing your Blog Page make sure that under "Page Attributes" on the right side choose the right template. Then just hit Update and you are ready to go.

  8. viclops
    Member
    Posted 11 months ago #

    But I am. It may not be showing up in the code, but that is how I have set up the page. For some reason it is not translating to the code. I can send you a screenshot to show you, if you want.

  9. Silkalns
    Member
    Theme Author

    Posted 11 months ago #

    Viclops,

    Please post a screenshot of Blog Page edit screen so I can see that you have setup it correctly.

    Unless you haven't modified the theme there is no way this information is not printed in website source.

  10. lpbaird
    Member
    Posted 2 months ago #

    I am having the same problem.

    Here is a screenshot of my Blog Page edit screen.

    http://s519402348.onlinehome.us/cherrygrovefarm/screenshot-blog-page-settings.jpg

    Here is a link to my blog page:

    http://s519402348.onlinehome.us/cherrygrovefarm/blog/

    Thanks for the terrific theme!

  11. lpbaird
    Member
    Posted 2 months ago #

    This seemed to fix it:

    Edit file library/structure/content-extensions.php (in my child theme directory)as follows:

    In line 133 change "the_excerpt" to "the_content"

    This is located about 40 lines below the comment:

    /**
    * Fuction to show the archive loop content.
    */

Reply

You must log in to post.

About this Theme

About this Topic