WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Blog post aren't showing up on my pages (16 posts)

  1. onthedl
    Member
    Posted 1 year ago #

    If anyone can shed some light. I'm new at wordpress.org and I don't know html coding etc. I've set up m site using a template and I can make blog posts, but they aren't showing up anywhere on my site. I want them to appear on a specific page within my site.

    Can someone please tell me what I might be doing wrong? I've searched a ton of threads for answers, I've uninstalled plugins etc. but nothing seems to be working. IS there something I should have checked off that I don't to make them appear?

    Also I have made the sidebar on my site invisible but there now seems to be something still there that prevents me from having a full page width so when I type everything is justified to the left.

    Lastly, Why can't I insert large images into my pages? If I try to the images get cut off/resized. I would like to insert an image the size of an actual page. IS this possible?

    Cheers!

  2. Aaron
    Member
    Posted 1 year ago #

    1. Posts not showing.

    What do you have set on Settings > Reading for home page and blog dropdowns?

    2. Sidebar invisible.
    If you go to edit that page on the right side under publish you should see templates. In that dropdown do you see full width?

    3. Images
    When inserting images right before you insert them the last setting is a bunch of radio buttons asking the site. Thumbnail, Medium, Large, Full Size. What are you selecting?

    What theme are you using?

  3. gpsy1
    Member
    Posted 1 year ago #

    Did you check settings >> reading?
    Do you have any post?

    Post the link of your blog.

  4. onthedl
    Member
    Posted 1 year ago #

    Update:

    I figured out that the static page is the front page. I want my landing page to be the static page, but I don't see an option to to do that. It will only allow me to chose another tab page. I now have my blog posts going to the right page, but my landing page is now my about page which is not what I want. I want the landing page to just the front/home page.

  5. Aaron
    Member
    Posted 1 year ago #

    Your landing page, if it is a page and not a post, should be in the dropdown on Settings > Reading to select for home page.

  6. gpsy1
    Member
    Posted 1 year ago #

    1. Latest post (All this depends on your choice, you can set home page to show latest post which wordpress is making automatically or create static page)
    2. Full width YES (This is in case if you want your page to be full width i just use the other one)
    3. I use Medium (how big you want your pictures in posts?)

  7. onthedl
    Member
    Posted 1 year ago #

    Sorry I'm just seeing your replies.

    Aaron: 1. I have the reading setting is now set to static page.
    2. I don't see templates on the right side or a drop down menu.
    3. I was selecting full size/100%

    Boban: I did make a test post. My link is http://www.dearlovely.com

    Thanks for the help guys!

  8. gpsy1
    Member
    Posted 1 year ago #

    I figured out that the static page is the front page. I want my landing page to be the static page, but I don't see an option to to do that. It will only allow me to chose another tab page. I now have my blog posts going to the right page, but my landing page is now my about page which is not what I want. I want the landing page to just the front/home page.

    Try creating new menu appearance >> menu and add new pages to it

  9. onthedl
    Member
    Posted 1 year ago #

    OK. So if you see my landing page which is the page with the banner of the girl drawing. This is the page I want to keep as my landing page, but it's not appearing in my drop down list. If you click on my logo at the top of all the pages right now it takes you back to my landing page which is what I want. Now I need to get my posts to appear on the page titled "Letters".

  10. Aaron
    Member
    Posted 1 year ago #

    Go to appearance > menu to get that menu option of home in there if your theme supports it.

    Edit your letters page and is there an option under templates for "blog"? If so select it and try.

    If not go to Settings > Reading and for blog page select letters from the dropdown.

  11. onthedl
    Member
    Posted 1 year ago #

    Ah Yes, that worked! Brilliant! Thank you!!!!

    Now about the page width problem. There seems to be some invisible wall on the right side of my pages. So basically if I make the side bar invisible I still can't seem to use that side of the page. It's acting as though there is still a side bar there. How do I change that?

  12. Hyper2k7
    Member
    Posted 1 year ago #

    You need to find the template drop down list under the publish button. It hasn't removed the sidebar.

    Have a look at http://www.stepbystepwebsites.co.uk/step-by-step-wordpress-tutorial-website/step-by-step-wordpress-pages-website/

    The template dropdown list it by the parent dropdown box.

    Hope this helps

  13. onthedl
    Member
    Posted 1 year ago #

    Hi Hyper,

    I tried what you suggested and there doesn't seem to be an option to remove it under that area hmmm Is there something I can do to change the page width? Maybe it's a code thing?

  14. onthedl
    Member
    Posted 1 year ago #

    Got the sidebar issue sorted! Thank you!

  15. preetipandit
    Member
    Posted 10 months ago #

    hello frnds.....

    I cannot see the posts list in the left sidebar on menus dashboard....

    theme locations
    custom links
    pages
    categories

    are seen..but posts arent visible...please help!!!!as i need to put the posts under a menu...but the posts list itself isn't seen......

  16. esmi
    Forum Moderator
    Posted 10 months ago #

    @preetipandit: As per the Forum Welcome, please post your own topic. This topic is 7 months old & references an older version of WordPress.

Topic Closed

This topic has been closed to new replies.

About this Topic