WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blog page says "ha" (6 posts)

  1. gman-1
    Member
    Posted 1 year ago #

    Hi,

    I updated from 3.5 to 3.5.1 yesterday. Now my blog page is blank, except for the letters "ha" in the upper left corner.

    So, I deleted my db, deleted my wordpress directory, downloaded a fresh wodrpress archive, unpacked it, created a new db, and reinstalled everything according to the docs.

    Once I was done, the same problem exists -- I have NOTHING installed by way of plugins, themes etc. It is a straight, out-of-the-box install of wordpress -- and it doesn't work. It is just the blog page that is cranky.

    Anyone have any idea of what is going on here, and how I can fix it?
    My ISP has PHP 4.4.9 and Mysql 5.

    And yes, I have expunged all cookies and temporary internet files and tried it on several different browsers. All have the same issue.

    Thanks!

    G

  2. Hi gman-1,

    Anyone have any idea of what is going on here, and how I can fix it?
    My ISP has PHP 4.4.9 and Mysql 5.

    PHP 5.2.4 or greater is required.
    Your host is not meeting the minimum requirements to run WordPress. While we try to stay as backwards compatible as possible with PHP versions older than the minimum requirements, it's just simply not possible and sometimes little changes will crash an older version.

    Can you set WP_DEBUG to true in your wp-config.php file then report back with the errors or provide a link to the page? This is really the only way we can help you find the actual problem.

  3. gman-1
    Member
    Posted 1 year ago #

    OK...

    I think I got this 1/2 way figured out at least. I was wrong about the php version. It is, infact, 5.2.17. I got that by issuing "php -v" on the command line, when I should have done "php5 -v". My bad.

    I have narrowed the problem down. It seems that it has to do with permalinks. When it is set to default, it works. When I choose any other option (I like to use post name, for example), it breaks.

    It may be because I have an .htaccess file on the server to move the document root to a different folder (one level down from the ISP default).

    I put this .htaccess file in the ISP designated document root:

    RewriteEngine On
    RewriteRule ^$ /wp/ [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteCond %{REQUEST_URI} !^/wp/
    RewriteRule ^(.*)$ /wp/$1
    RewriteCond %{SCRIPT_FILENAME} -d
    RewriteRule ^mywebsite.com/(.*[^/])$ http://www.mywebsite.com/$1/ [R=301]

    So the new document root is ${ISPROOT}/wp

    I have done this before on other wordpress websites with no problems, and I cannot see what would cause the issue... but I suppose it behooves me to try it without just to see what happens...

  4. gman-1
    Member
    Posted 1 year ago #

    Yep... that is, apparently, causing the problem...

    Any apache gurus out there know what is wrong here? How can I alter this so that it doesn't munge my permlinks?

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    I have an .htaccess file on the server to move the document root to a different folder (one level down from the ISP default).

    You might want to discuss that with the hosts. I think you'll find that there are a few hosts out there that will block that kind of redirection.

  6. gman-1
    Member
    Posted 1 year ago #

    I decided to skin this potato another way:

    RewriteEngine on
    RewriteCond %{HTTP_HOST} ^mywebsite.com$ [NC,OR]
    RewriteCond %{HTTP_HOST} ^www.mywebsite.com$
    RewriteCond %{REQUEST_URI} !wp/
    RewriteRule (.*) /wp/$1 [L]

    And this works :D

    Thank you for your quick response Chris and esmi!

    -G

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags