WordPress.org

Ready to get started?Download WordPress

Forums

Blog page problems (4 posts)

  1. frenetic
    Member
    Posted 8 years ago #

    Blog page problems

    In 1.5.2 I had hacked in a static front page and moved my main blog page to /blog/ (though the archives were still at /archives/). After upgrading everything's working except for my redirect to take people to the blog page when they hit /blog/. Here's a bit of my .htaccess file:

    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^bradsucks\.net
    RewriteRule ^(.*)$ http://www.bradsucks.net/$1 [R=301,L]
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [S=90]
    RewriteRule ^(blog)/?$ /index.php?place=blog [QSA,L]

    Going to http://www.bradsucks.net/blog/ gets me a wordpress 404 error (loads 404.php in the theme.) Going to http://www.bradsucks.net/index.php?place=blog shows me the page I want.

    If I change the [QSA,L] to [R=301,L], it works but then has an ugly URL when it forwards. I'm not fantastic with mod rewrite, but this is confusing me. Thanks for any help you can offer.

  2. schestowitz
    Member
    Posted 8 years ago #

    I think this might be related to the following:

    http://trac.wordpress.org/ticket/2169

    A few hours ago, someone raised similar concerns. S/he was merging FrontPage rules with rules for WP 2.0.

  3. frenetic
    Member
    Posted 8 years ago #

    Looks pretty similar. They were satisfied with doing a full redirect though and that's not quite what I want.

    I've managed to hack in a blog page using the paging system now, but it's a pain. If it was clearly a change in functionality between versions I'd understand, but this just seems random and bizarre.

  4. schestowitz
    Member
    Posted 8 years ago #

    This seems to have been resolved in another thread

Topic Closed

This topic has been closed to new replies.

About this Topic