WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blog page not working after permalinks changed (13 posts)

  1. ncharshaf_design
    Member
    Posted 4 years ago #

    The site I am working on can be found here: http://www.richard-gaston-photography.com

    I have my wordpress installed in a subdirectory located at /news. I then use the home page for a static page, with my blog then located within the /news folder.

    This setup works perfectly when I have the default ugly permalinks setup.

    However, I just changed my permalinks to do Day and Name, and now my link for my blog shows an error page that Directory has no index file.

    All of my other links work great, it is just the blog page that is missing at this point.

    Please let me know what I need to do to get this page back

    Thanks

  2. s_ha_dum
    Member
    Posted 4 years ago #

    Did you update your .htaccess file? You are given instructions everytime you save a permalink structure.

  3. ncharshaf_design
    Member
    Posted 4 years ago #

    This is what was generated for wordpress for the new permalink structure

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

  4. s_ha_dum
    Member
    Posted 4 years ago #

    OK. Now, is that text actually in a .htaccess file? WordPress cannot always create/edit that file for you.

  5. Royalty
    Member
    Posted 4 years ago #

    It's funny I'm having the same problem I think.

    Once I change my permalinks structure to %category%/%postname% the posts didn't seem to work and they're giving me 'can't found on sever' error.

    Do I have to edit another file when I change my permalinks structure?

    I'm using WAMP by the way, does it matter?

  6. ncharshaf_design
    Member
    Posted 4 years ago #

    yes I went on my host and copied the text as it stood in the file

  7. s_ha_dum
    Member
    Posted 4 years ago #

    OK. Something is odd. WP files appear to be in '/news/' but http://www.richard-gaston-photography.com/?p=2 redirects to the '/About/' page as it would if it were a wordpress page... which it is. So I guess what you've tried to do is something like what is described here but something has gone wrong. You've set siteurl to root and blogurl to '/News/'. Sound about right?

  8. ncharshaf_design
    Member
    Posted 4 years ago #

    Yes, In my settings I have:

    WordPress address (URL) http://www.richard-gaston-photography.com/news

    Blog address (URL) http://www.richard-gaston-photography.com

    I guess the only thing I can think of is that all of my other pages are actual pages I have created where the blog page has always just "worked". There is not a .php file in my directory that I can point to, or a page that I have created to point to.

    You can view my posts fine if you click on them from the side, a sample url of those is:
    http://www.richard-gaston-photography.com/2009/11/19/post-processing/

    This URL dos not really give me any idea of how to access my blog though, since in normal situations I would think that this would mean that my blog would be found at the site root, which is not the case.

  9. ncharshaf_design
    Member
    Posted 4 years ago #

    I ended up messing around a bit and fixing this issue.

    For anyone else having this issue here is what I did:

    I think the issue may have been that I was naming the blog the same as I was naming my subdirectory that I had wordpress installed in. So, I had all of my files inside of a folder named news, and I was trying to have my blog page named news. This was causing it to go to the /news directory and not finding an index file. I renamed my wordpress page "blog" and changed the permalink.

  10. s_ha_dum
    Member
    Posted 4 years ago #

    I think the issue may have been that I was naming the blog the same as I was naming my subdirectory that I had wordpress installed in. So, I had all of my files inside of a folder named news, and I was trying to have my blog page named news.

    This is exactly what I was wondering about but I didn't know for sure if was a problem because I've never tried it and didn't have time to do any testing. Glad you worked it out.

  11. mrloo
    Member
    Posted 4 years ago #

    I am having problems with my permalink when I upgraded with 2.9.2. My permalink used to show like this:

    OLD: http://digifotoblog.com/speak-thai-101-greetings/

    NOW the permalink shows like this

    NEW: http://digifotoblog.com/?p=461

    HOw can I go back to my old permalink http://digifotoblog.com/speak-thai-101-greetings/? Most of my most visited links are not accessible anymore.

    Please help

  12. mrloo
    Member
    Posted 4 years ago #

    Problem solved, this is what I've done.

    I changed the custom structure to /%postname%/

    And it worked.

    Whew!!!

  13. ElisaJo
    Member
    Posted 3 years ago #

    Hi there,

    I think I sort of have the same problem as the top post.

    My site has a static homepage and a sepparate postpage for all the posts. It all worked until I changed the permalinks into prettylinks. I installed htaccess and all the pages turned into pretty urls, except for the newspage that showed "Sorry, but you are looking for something that isn't here."

    If I change it back again to default, then everything is fine again.

    I don't think I'm using the same name in subdirectory or something like that (as the solution above)

    What can I do? (oh, and i'm not very technical)

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic