WordPress.org

Ready to get started?Download WordPress

Forums

blog page is same as static homepage (7 posts)

  1. sharon lee
    Member
    Posted 6 years ago #

    Hi guys

    I have created a static homepage that works fine, but my blog has since disappeared and seems to have been replaced by the index (home.php). I can only conclude that I have written over the original blog file but don't know how to rectify this. Any ideas? I have tried everything I know to fix it but seem to be going round in circles now! I originally used the sandbox theme but not sure if this is relevant...

    I'd really appreciate any input...

    cheers
    Sharon

  2. LongSpoon
    Member
    Posted 6 years ago #

    Hi Sharon,
    I am afraid I cannot answer your question, but would appreciate any tips on how you set up you blog page as your home page, as this is what I am trying to do right this second...
    Kind Regards
    Paul

  3. sharon lee
    Member
    Posted 6 years ago #

    Hi Paul

    I referred to the following link to set up my static homepage:

    http://www.wordpressmax.com/customize-wordpress/custom-page

    There is a detailed step-by-step 'how to' video. The example uses an older version of wordpress but the principle remains the same.

    You can set your 'front page display' to 'a static page' via the 'settings' tab in the dashboard in the latest version of wordpress.

    Hope this helps.

  4. sharon lee
    Member
    Posted 6 years ago #

    RE: My original problem. Whoops sorry. I totally forgot to post the link to the blog site I'm developing!
    http://cyonix.co.uk/wordpress/

    Hope somebody can shed some light on this matter...

  5. sharon lee
    Member
    Posted 6 years ago #

    Can I supply more information for help on this matter?

  6. ipears
    Member
    Posted 6 years ago #

    Sharon, I think this problem is less complicated than it seems to be.

    Rather than using the before mentioned script, you can simply set 1 page to act a "front-page" and have your posts appear in another page (blog).

    Check the following in the codex: Using a Page as the front page

    I think that that gives the needed solution!

  7. sharon lee
    Member
    Posted 6 years ago #

    Hi ipears

    Thanks for the reply...

    I am aware of these settings. However, even if I set it to 'Your latest posts' setting it STILL shows the static page that I had previously set it to. Could this be something to do with the static page file name being home.php?

    I'm also convinced that whilst creating the static homepage (creating my own templates), Ive written over some vital page in the root that is required to run the blog (containing the loop). As I am newish to wordpress, I'm a little lost with the situation...Help :-)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.