WordPress.org

Ready to get started?Download WordPress

Forums

Blog on forums (16 posts)

  1. dzignerweb
    Member
    Posted 8 years ago #

    There is a great feature on http://www.webmaster-talk.com/ forums, where you can have the latest feed from your blog under your avatar. A great way to get traffic.

  2. whooami
    Member
    Posted 8 years ago #

    feedburner has a system that will allow you to advertise on any forum, assuming the forum allows signatures.

    I also wrote up a how-to on another way well over a year ago:
    http://wordpress.org/support/topic/21598?replies=1

  3. carnold
    Member
    Posted 8 years ago #

    @whooami-i always get a blue screen with "piss off a__hole" when trying to get to your site. Why? Do you not allow dhcp people to your site or something?

  4. resiny
    Member
    Posted 8 years ago #

    carnold- it might be a spam plugin like bad behaviour that blocks access attempts from what it believs to be spambots...

  5. carnold
    Member
    Posted 8 years ago #

    Certianly, not a spambot. I have bad behaviour and SK2 installed for spam, am i blocking people too, unknowingly?

  6. resiny
    Member
    Posted 8 years ago #

    it's quite possible.

    I wasn't saying you were a spambot, but that his anti spam bot plugin might think you are

  7. Samuel B
    moderator
    Posted 8 years ago #

    I think she's doing it with an .htaccess redirect?
    Feel free to corect me, whooami.

    p.s. Your site always gives me a chuckle - maybe because I'm a village idiot, too. :>)

  8. whooami
    Member
    Posted 8 years ago #

    carnold, do you happen to be in Brazil? Looking at your site (the one listed in your profile here), I dont think you are. I certainly dont block people on dhcp from accessing my site -- that would do away with nearly every cable user on the net, including myself :)

    There is a chance that your ip is included in a range thats being blocked, whats the first 2 octets of your ip?

    the page youre seeing is my 403, by the way, "access denied" ie, typically only seen by someone with an ip thats been tagged by me as being spammy. Not that youre spammy or anything. Like I said, if I have your first 2 octets, I can surely fix it.

  9. carnold
    Member
    Posted 8 years ago #

    I too have a problem with certain ip's and would like to block them. Do you mind sharing how you block your ip's? I use a htaccess <limit> from here codex.wordpress.org/Combating_Comment_Spam/Denying_Access but this does not seem to work (these 2 ip's always seem to get through. Anyway, here are the first 2 octets of my ip 24.163
    Thanks
    Forgot to add, i am not in Brazil.

  10. whooami
    Member
    Posted 8 years ago #

    carnold, your ip isnt being blocked, so Im at a loss. Thats nearly 80% of the American/Canadian population :) I also block some referers, but obviously wordpress.org isn't one of them :) though.

    I use a combination of things -- the standard mod_access (thats what you just described using), a little mod_rewrite, and just recently Ive beefed things up with mod_security.

    Ill happily make my .htaccess available on another site if youre interested in looking at it -- perhaps you can figure out what might be blocking you?

    btw, I can prolly help you with the ip problme, what are they, and what are using to block them? specifically.. what do the deny from .. lines look like?

  11. carnold
    Member
    Posted 8 years ago #

    I would be most interested in seeing your htaccess file. The ip's that keep getting through are:
    81.177.14.*
    81.177.15.*
    208.66.193.*
    My htaccess is relatively small, so i will post it here:
    <Limit GET>
    order allow,deny
    deny from 81.177.14.*
    deny from 81.177.15.*
    deny from 208.66.193.*
    deny from 789.789.*.*
    allow from all
    </Limit>
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    RewriteCond %{REQUEST_METHOD} POST
    RewriteCond %{REQUEST_URI} .wp-comments-post\.php*
    RewriteCond %{HTTP_REFERER} !.*mytimewithgod.net.* [OR]
    RewriteCond %{HTTP_USER_AGENT} ^$
    RewriteRule (.*) ^http://%{REMOTE_ADDR}/$ [R=301,L]
    RewriteCond %{REMOTE_ADDR} =80.77.81.190 [OR]
    RewriteCond %{REMOTE_ADDR} =81.177.14.* [OR]
    RewriteCond %{REMOTE_ADDR} =81.177.15.40 [OR]
    RewriteCond %{REMOTE_ADDR} =81.177.15.41 [OR]
    RewriteCond %{REMOTE_ADDR} =81.177.15.42 [OR]
    RewriteCond %{REMOTE_ADDR} =81.177.15.43 [OR]
    RewriteCond %{REMOTE_ADDR} =81.177.15.48 [OR]
    RewriteCond %{REMOTE_ADDR} =217.39.10.127 [OR]
    RewriteCond %{REMOTE_ADDR} =200.250.100.131 [OR]
    RewriteCond %{REMOTE_ADDR} =208.66.193.4 [OR]
    RewriteCond %{REMOTE_ADDR} =208.66.193.5 [OR]
    RewriteCond %{REMOTE_ADDR} =208.66.193.24 [OR]
    RewriteCond %{REMOTE_ADDR} =208.66.193.23 [OR]
    RewriteCond %{REMOTE_ADDR} =208.66.193.10 [OR]
    RewriteCond %{REMOTE_ADDR} =212.248.245.241 [OR]
    RewriteCond %{REMOTE_ADDR} =195.248.102.88
    RewriteRule .* - [F]
    # END WordPress
    As far as mod_access mod_rewrite, and mod_security; are these mods_ of apache that must be installed? I run Linux on this server and just looked in "add/remove software (yast) for mod_ and did not see any of those listed. Just curious as to how you got these working. Gonna do some googling..Thanks for all your help!

  12. whooami
    Member
    Posted 8 years ago #

    ok! the problem with your mod_access stuff is that you are using astericks for your wildcards -- that wont work, mod_access doesnt recognize them.

    Also, the limit get, stuff .. thats covering an http_get (the normal way pages are called); that wont cover http_posts, the way comments are sent.

    So do this:

    1. kill the <limit get> tag, and the closing </limit> tag completely, or use <limit POST> and </limit>

    then ..

    order allow,deny
    allow from all
    deny from 81.177.14
    deny from 81.177.15.
    deny from 208.66.193.
    deny from 789.789.

    OR use the CIDRs to cover that entire range:

    deny from 81.177.14.1/32
    deny from 81.177.14.2/31
    deny from 81.177.14.4/30
    deny from 81.177.14.8/29
    deny from 81.177.14.16/28
    deny from 81.177.14.32/27
    deny from 81.177.14.64/26
    deny from 81.177.14.128/25
    deny from 81.177.15.0/24

  13. whooami
    Member
    Posted 8 years ago #

    You can also remove the mod_rewrite lines youve used below to try and block those offending IPs down below, after you've done the above stuff correctly.

    Here's the trick, if something isnt working, its best to track down whats broke and fix that, rather than adding more lines, that might be broke as well. :)

    PS: are you sure you have mod_access installed? If you add one of your own IPs to a deny statement, are you kept out?

    I ask this because it has come up -- someone was trying to use it, and didnt have it available.

    Re. your questions,

    Yes, mod_security, mod_access, and mod_rewrite are compiled into Apache when you build it (on a *NIX box). You have pretty permalinks, so you have mod_rewrite installed.

    The best thing to do is to create a phpinfo.php, and drop the following into it:

    <?php phpinfo(); ?>

    Open that up in your browser, scroll down to where you see Apache, and it will list the installed modules. Or, if you have shell access (which it sounds like you do), look around in /usr/lib/apache/ for a modules directory ..you will see what youve installed.

    Youre using SUSE? I reccommend Apache Toolbox for setting up and compiling Apache. It will give you complete control over the hows and whats of Apache, and download the current modules as you pick and choose them:

    http://www.apachetoolbox.com/

  14. whooami
    Member
    Posted 8 years ago #

    thats alot of info to digest, and unfortunately, Im out the door -- need to take my mom to the hospital and then go straight to work. Ill check back in 10 hours to see how youve done.

    Good luck, and happy Googling!

  15. carnold
    Member
    Posted 8 years ago #

    PS: are you sure you have mod_access installed? If you add one of your own IPs to a deny statement, are you kept out?
    Below is a list of the mods installed. Also, i added my local ip (192.168.123) to the deny list and was not able to get to the site with Limit GET. Changed to Limit POST and was not able to post comments! Thank you for that bit of info!
    mods installed: core prefork http_core mod_so mod_suexec mod_access mod_actions mod_alias mod_auth mod_auth_dbm mod_autoindex mod_cgi mod_dir mod_env mod_expires mod_include mod_log_config mod_mime mod_negotiation mod_setenvif mod_userdir mod_ssl sapi_apache2 mod_jk mod_rewrite mod_mono mod_ipp util_ldap2 mod_auth_ldapdn mod_headers mod_xsrv
    Yes, i am using SUSE OES-Linux (based on SLES9). Thank you for the apachetoolbox link! I do not see mod_security in those installed mods so i am going to download the apachetoolbox and see if i can't get mod_security installed.

  16. whooami
    Member
    Posted 8 years ago #

    btw, i forgot a . in that one post :

    deny from 81.177.14. <--
    deny from 81.177.15.

Topic Closed

This topic has been closed to new replies.

About this Topic