WordPress.org

Ready to get started?Download WordPress

Forums

blog link: Error establishing a database connection (18 posts)

  1. nd6
    Member
    Posted 1 year ago #

    Hello Guys and Girls,

    Lately im ussing the pitch theme but my blog link doesnt work. i simply get Error establishing a database connection.
    I read teh other forum questions and answers. But i do not understand. Mostly its about Error establishing a database connection for the whole site , but now i have it for only one link : http://www.versevorm.nl/blog/

    Please, does somebody know how to solve this?

  2. Bas Schuiling
    Member
    Posted 1 year ago #

    Maybe you have another wordpress installation running on /blog ? I looks like it picks a different wp-config.php file or so.

  3. nd6
    Member
    Posted 1 year ago #

    Hello basszje,

    Wouw thanks for looking! Shall i configure my wp-config.php?
    And which rule shall i confige from my php to activate teh blog link wright?

    // ** MySQL settings - You can get this info from your web host ** //
    /** The name of the database for WordPress */
    define('DB_NAME', 'nuriect91_wp1');
    
    /** MySQL database username */
    define('DB_USER', 'xxxxxx_wp1');
    
    /** MySQL database password */
    define('DB_PASSWORD', 'xxxxx');
    
    /** MySQL hostname */
    define('DB_HOST', 'localhost');
    
    /** Database Charset to use in creating database tables. */
    define('DB_CHARSET', 'utf8');
    
    /** The Database Collate type. Don't change this if in doubt. */
    define('DB_COLLATE', '');
  4. nd6
    Member
    Posted 1 year ago #

    I've deinstalled en installed wordpress manny times, also the pitch theme i uploaded different times. resetted....It seems the the config is alright? where is the problem?

  5. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Is this a separate install in your domain's /blog sub-folder?

  6. nd6
    Member
    Posted 1 year ago #

    Hi esmi diva,

    Im not so technical , what do you mean with a subfolder? Where must i look to know what you mean.

    greeting from me

  7. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    You already have WordPress installed on your root domain: http://www.versevorm.nl/ Are you trying to install a second copy of WordPress on the same domain?

  8. nd6
    Member
    Posted 1 year ago #

    Hello esme diva,

    I have only installed 1 wordpress on that site adres for as far as i know, if else where can i see that?
    Thanks for the reply and thinking with me!:)

  9. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    OK. Are you using custom permalinks on your site? If so, what structure and has your .htaccess file been properly updated?

    Have you actually created a static Page - through WordPress - called "Blog" and made this your main posts page?

  10. nd6
    Member
    Posted 1 year ago #

    I search in the direct administration and saw that there was no subdomain. it that is what you mean esmi diva ;)

  11. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    No - I said a sub-folder called blog.

  12. nd6
    Member
    Posted 1 year ago #

    Hello esmi diva,

    I made my home page the blog page and tested if it works with the static front page, but no results. Im still missing the link and are getting Error establishing a database connection. How can ik resore this blog link. The rest of the site works good.

    Thanks for your time!

  13. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Do you have a folder in your site/domain called blog? If so, remove it.

  14. nd6
    Member
    Posted 1 year ago #

    Hello esmi diva,

    I looked in the files in the direct admin and only saw one folder that is called blog and in teh editor in worpress i only see: Blog Page Template
    (page-blog.php)
    no other blog php

    :(

  15. nd6
    Member
    Posted 1 year ago #

    In the folder wp-content i found a folder names blogs.dir, could this be the problem?

  16. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Delete or rename the blog folder

  17. nd6
    Member
    Posted 1 year ago #

    Wauw you are magical!!

    Now i can see if i can link a page to the link blog! ;))))
    What could have been the problem???after i renamed the folder blog, it worked!!!!!!

  18. esmi
    Theme Diva & Forum Moderator
    Posted 1 year ago #

    Excellent ! :-)

Topic Closed

This topic has been closed to new replies.

About this Topic