WordPress.org

Ready to get started?Download WordPress

Forums

blog homepage (9 posts)

  1. barnisays
    Member
    Posted 2 years ago #

    Hi,
    Please, i want to power my site on the browser as http://mydomain.com. I actually installed WordPress in a sub-directory folder with this path http://mydomain.com/myblog. I want to give my friends the site url as http://mydomain.com and not as http://myblog.com/myblog. Also, in the general setting, which one should contain the full path? Thanks in anticipation for any instruction you can render.

  2. edwinmcneil26293
    Member
    Posted 2 years ago #

    Hi I want to know too.
    Have found the way to do that ?

    [ Sig moderated as per the Forum Rules ]

  3. jsyrett
    Member
    Posted 2 years ago #

    Try a server side redirect

  4. barnisays
    Member
    Posted 2 years ago #

    Thanks jsyrett, server side redirect...how?

  5. snaushads
    Member
    Posted 2 years ago #

    @barnisays, You can visit your hosting control (depends what hosting you are using) panel and add a redirection from
    http://mydomain.com
    TO
    http://mydomain.com/myblog

    Anyone who visits http://mydomain.com, will be redirected to http://mydomain.com/myblog.

  6. esmi
    Forum Moderator
    Posted 2 years ago #

  7. barnisays
    Member
    Posted 2 years ago #

    hi snaushads,
    thanks for your tip but that not what i want. i want people to type htt://mydomain.com on their browser and see the blog and not with this url htp://mydomain.com/myblog. @ esmi, will read the article, thanks alot.

  8. barnisays
    Member
    Posted 2 years ago #

    esmi, have read the article. But i have already installed my blog to its directory e.g http://mydomain.com/myblog. Now i want to give people my url as http://mydomain.com without the sub-directory /"myblog. How will i ask Mr WordPress to do it?

  9. barnisays
    Member
    Posted 2 years ago #

    Thanks a lot to esmi, jsyrett and snaudhad. I thank jysrett specifiacally because i used your tip by redirecting the files in my blog folder present in the root folder back to the root folder and changing the setting on my dashboard to my domain name without the /myblo suffix. Though, had problem with signing into wp dashboard however, it's solved. So happy!

Topic Closed

This topic has been closed to new replies.

About this Topic