WordPress.org

Ready to get started?Download WordPress

Forums

Blog home page is redirecting to website home page (10 posts)

  1. vonyaglobal
    Member
    Posted 9 months ago #

    my blog site is redirecting to my company home page, but I didn't set it to do so. .htaccess looks fine, 301 redirects file looks fine. I can't figure it out.

    Blog home: http://www.vonyaglobal.com/internal-audit/
    company home: http://www.vonyaglobal.com/

    The site has been working fine for a year, just noticed the change this week. I am not a WP super user but have a general knowledge.

  2. Krishna
    Volunteer Moderator
    Posted 9 months ago #

    Do you have WordPress installed in your blog? If so, check if you have a file with the name index.html at the root of that blog folder.

  3. vonyaglobal
    Member
    Posted 9 months ago #

    Krishna, thanks for responding. The index.html file in not in the root directory. I am guessing that it should be? What should it contain?

  4. vonyaglobal
    Member
    Posted 9 months ago #

    the WP install is located at http://www.vonyaglobal.com/internal-audit/

    the website's home page is http://www.vonyaglobal.com/index.html

  5. Krishna
    Volunteer Moderator
    Posted 9 months ago #

    I get this URL when I try to visit your blog:
    http://www.vonyaglobal.com/index.html

    That obviously is being redirected from your blog. That means either there will be a redirection in your .htaccess file or using some other file or plugin. Look for it.

  6. Krishna
    Volunteer Moderator
    Posted 9 months ago #

    I find a file named index.html in your blog directory. Can you locate it, save a copy of that to your computer and then delete it or rename it?
    Look at the links here: http://sitecheck.sucuri.net/results/www.vonyaglobal.com/internal-audit/

  7. vonyaglobal
    Member
    Posted 9 months ago #

    I added the index.html file on the blog directory after the earlier response. I deleted it.

    Here is the .htaccess file. Looks fine:
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /internal-audit/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /internal-audit/index.php [L]
    </IfModule>

    # END WordPress

  8. Krishna
    Volunteer Moderator
    Posted 9 months ago #

    I still find the index.html file.

    Can you check if you have your reading settings (dashboard) as in this image or something else?

    http://codex.wordpress.org/images/2/25/options-reading.png

  9. vonyaglobal
    Member
    Posted 9 months ago #

    The index file should be on my main directory vonyaglobal.com, but should have been removed from vonyaglobal.com/internal-audit/

    The reading settings are the same as the image.

  10. vonyaglobal
    Member
    Posted 9 months ago #

    I figured out a work around but would like a real solution. I changed General Settings, Site Address (URL) http://www.vonyaglobal.com/internal-audit/knowledge/ and then created a category "knowledge" and have begun adding that category to each of my posts. Seems to work for now... I appreciate your help today. If you think of something else please let me know.

Reply

You must log in to post.

About this Topic