WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Blog followers not receiving images in their mails (10 posts)

  1. Mr Eddy
    Member
    Posted 1 year ago #

    Hello,

    I'm experiencing an issue recently. My followers (and I) are not getting the images that are in my posts when they receive an email about a new post.
    It used to work perfectly in fact.

    Since I didn't published in the last 3 months, this may be related to a Jetpack update OR a WordPress update. But I haven't done anything else to my website.

    Those images are on located on my Photoshelter, and I'm using the plugin they provide to add them in my blog.

    Does anyone knows if I can do something to correct this ? Since my blog is about photography, not having the images along in the mail when I add a new post is very frustrating.

    Best regards,

    Eddy

    PS : Here is my website by the way if needed : http://www.mr-eddy.com/

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I had a look at your RSS feed, and it seems to include only a Summary of your posts:
    http://www.mr-eddy.com/feed/

    Could you go to Settings > Reading in your dashboard, and set your Feed settings to "Full Post"?

    Jetpack will then grab the whole content of your posts, including the images you may have inserted into your post.

  3. Mr Eddy
    Member
    Posted 1 year ago #

    Yes I use the "more" tag in fact. But I include a picture before this tag in every post and it was perfectly working.
    You may have a look at another website I'm following to compare : http://www.ishootshows.com
    Every time i receive an email for his new posts, their is a picture included.

    Again, all I have done is updating jetpack and wordpress in the last month. For example on my last post I added a caption to the first picture. In my email, I was able to see the caption in its preview (using Mail on a mac), but in the real mail no picture. So at least it "sees" their is something.

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    You may have a look at another website I'm following to compare : http://www.ishootshows.com

    This site's feed settings are set to "Full Text", while yours are stil set to "Summary".

    You can compare the 2 sites by looking at the RSS feeds:

    One of them includes the <content:encoded> field, while the other doesn't.

    Could you try to change the feed settings, and let me know if this helps?

  5. Mr Eddy
    Member
    Posted 1 year ago #

    It seems to be working again by turning the feed settings to full text, even though it's not sending full text in the mail or on the feed.

    Thanks for your quick help !

  6. Mr Eddy
    Member
    Posted 1 year ago #

    PS : I couldn't find the <content:encoded> in the source page of the feed. Where is it located ?

  7. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    You can find it below the <description> tag:
    http://i.wpne.ws/MXTU

    I subscribed to your site, and will let you know if the new Feed settings work as soon as I receive the first notification email.

  8. Mr Eddy
    Member
    Posted 1 year ago #

    Oh thanks that's very kind of you !
    I'll be posting around 12PM today (UTC+1), so you should get an email a few minutes later if everything is okay.

  9. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I just received the email, and everything above the <!--more--> tag seems to be displayed properly now:
    http://i.wpne.ws/MXov

  10. Mr Eddy
    Member
    Posted 1 year ago #

    That's exactly how it should look :)
    Thanks once again for your help !

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic