WordPress.org

Ready to get started?Download WordPress

Forums

Blog error message after upgrading... (6 posts)

  1. altruistic
    Member
    Posted 6 years ago #

    Hi Guys!

    I just upgrade from WordPress 2.2.3 to 2.3 and I ran the data base upgrade script and this is what I see:

    WordPress database error: [Table 'jcroot_myblog.wp_terms' doesn't exist]
    SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category') AND t.slug = 'upgradephp' ORDER BY t.name ASC

    WordPress database error: [Table 'jcroot_myblog.wp_terms' doesn't exist]
    SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category') AND t.slug = 'upgradephp' ORDER BY t.name ASC

    WordPress database error: [Table 'jcroot_myblog.wp_terms' doesn't exist]
    SELECT t.*, tt.* FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON t.term_id = tt.term_id WHERE tt.taxonomy IN ('category') ORDER BY t.name ASC

    WordPress database error: [Table 'jcroot_myblog.wp_term_relationships' doesn't exist]
    SELECT SQL_CALC_FOUND_ROWS wp_posts.* FROM wp_posts LEFT JOIN wp_term_relationships ON (wp_posts.ID = wp_term_relationships.object_id) LEFT JOIN wp_term_taxonomy ON (wp_term_relationships.term_taxonomy_id = wp_term_taxonomy.term_taxonomy_id) WHERE 1=1 AND wp_term_taxonomy.taxonomy = 'category' AND wp_term_taxonomy.term_id IN ('0') AND post_type = 'post' AND (post_status = 'publish' OR post_status = 'future' OR post_status = 'draft' OR post_status = 'pending' OR post_status = 'private') GROUP BY wp_posts.ID ORDER BY post_date DESC LIMIT 0, 5

    Also... I'm not able to see my blog correctly, I don't know why but when I try to see my blog I get the following error message:

    WordPress database error: [Table 'jcroot_myblog.wp_terms' doesn't exist]
    SELECT t.*, tt.*, tr.object_id FROM wp_terms AS t INNER JOIN wp_term_taxonomy AS tt ON tt.term_id = t.term_id INNER JOIN wp_term_relationships AS tr ON tr.term_taxonomy_id = tt.term_taxonomy_id WHERE tt.taxonomy IN ('category', 'post_tag') AND tr.object_id IN (107, 110, 112, 111, 108) ORDER BY t.name ASC

    Can somebody please give me a hand with this?

  2. Stevie212
    Member
    Posted 6 years ago #

    GRR this is the same problem everybody is getting.

    http://wordpress.org/support/topic/135512

    It is most likely an outdated plugin, disable it!

  3. altruistic
    Member
    Posted 6 years ago #

    Hi!

    Well I disabled all the plug in before running the upgrade... I don't know why is doing this...

    Any other help?

  4. spencerp
    Member
    Posted 6 years ago #

    Can you please login to your phpMyAdmin and check for those three tables in your blogs database, and make sure they are there for sure?

  5. Minger
    Member
    Posted 6 years ago #

    i have the same problem. i upgraded using the svn method and have this error despite deactivating all plugins. the presence of the tables is confirmed by checking the tables with mysql gui.

    thank goodness for backups! i'll wait for 2.3.1 or .2

  6. George
    Member
    Posted 6 years ago #

    I had the same problem. With the conversion the database went kaput. Install the backup of your database via MyPHP. Then ugrade.php again. I hope you did make a backup.
    This is not a plugin problem, I doubt it has to do with categories or tags.

    http://wordpress.org/support/topic/135680?replies=3#post-621125

Topic Closed

This topic has been closed to new replies.

About this Topic