WordPress.org

Ready to get started?Download WordPress

Forums

Blog entry only showing excerpt (3 posts)

  1. katiebegood
    Member
    Posted 2 years ago #

    Ok, I don't know what I have done wrong here. I have my website set up with a static homepage and a "Blog" page to gather all my blog entries. For some reason the blog page is only showing an excerpt of the blog entry. I would like the entire blog entry to show up, not just an excerpt. I'm not sure where I have set something that is causing this to happen. I've checked my setting and don't see anything wrong there. The site is: http://www.tilapiaacuaculturayucatan.com/.

    Can anyone figure out what is causing this?

  2. alchymyth
    Forum Moderator
    Posted 2 years ago #

    have you tried to check if index.php, or whtever template shows the blog page http://codex.wordpress.org/Template_Hierarchy , is using the_excerpt() or the_content() in the loop?

    http://codex.wordpress.org/Function_Reference/the_excerpt

  3. katiebegood
    Member
    Posted 2 years ago #

    Ok, here's the solution I found (in case someone else has the same problem).

    I did a search on the .php files with TextPad for "excerpt". I found that in content.php. I changed "theme_get_excerpt()" to "theme_get_content()" in the following text.

    <?php
    global $post;
    theme_post_wrapper(
    array(
    'id' => theme_get_post_id(),
    'class' => theme_get_post_class(),
    'thumbnail' => theme_get_post_thumbnail(),
    'title' => 'ID ) . '" rel="bookmark" title="' . get_the_title() . '">' . get_the_title() . '',
    'before' => theme_get_metadata_icons( 'date,author,edit', 'header' ),
    'content' => theme_get_excerpt(),
    'after' => theme_get_metadata_icons( '', 'footer' )
    )
    );
    ?>

    Worked like a charm.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.