WordPress.org

Ready to get started?Download WordPress

Forums

Blog Disaster: 'enable sending referrers' (6 posts)

  1. allotherplaces
    Member
    Posted 8 years ago #

    I have a series of blogs I've given out to friends at allotherplaces.org - ildiko is one of them.

    Today she emailed me asking why she couldn't add links any longer and said she got the following message:

    <b>Sorry, you need to enable sending referrers for this feature to work.</b>

    'enable sending referrers' links to
    http://codex.wordpress.org/Enable_Sending_Referrers

    So, I went to that Codex page....0

    That Codex page says:
    'Subdomains may also create problems.'

    so I changed the 'WordPress address (URI):' from
    http://ildiko.allotherplaces.org
    to
    http://allotherplaces.org/ildiko

    I should have known this was going to be a disaster, but against my better judgement I tried this and now I have messed up Ildiko's website { http://ildiko.allotherplaces.org } and now <b>ironically</b> I, as the Admin, get the message: <b>Sorry, you need to enable sending referrers for this feature to work.</b>

    <b>First Question:</b> How do I undo this mess to the way it was before?

    <b>Next Question:</b> How do I fix this 'enable sending referrers' issue so ildiko can add links to her blog again?

  2. allotherplaces
    Member
    Posted 8 years ago #

    Oh, I should have explained more clearly that I changed it back in the general options settings to what it was before:

    WordPress address (URI): http://ildiko.allotherplaces.org
    Blog address (URI): http://ildiko.allotherplaces.org

    and that this is WordPress 2.0

    and now i get the message:
    Sorry, you need to enable sending referrers for this feature to work

  3. Mark (podz)
    Support Maven
    Posted 8 years ago #

    If you upgrade to the latest version that error should go away.

  4. allotherplaces
    Member
    Posted 8 years ago #

    thanx Podz - I was wondering if that would do it - but from what Ive been reading I wasn't sure.

    I'll give it a try and report back

  5. manstraw
    Member
    Posted 8 years ago #

    A lot of people have Norton Internet Security, or some other kind of firewall etc. that strips the referrers. One can change those settings, which are on by default in NIS. It's possible that browser settings need to be changed too. I'm inferring from what podz is saying that the referrer security check has been loosen in the newest wordpress. I think I would prefer the referrer check happen actually.

  6. allotherplaces
    Member
    Posted 8 years ago #

    Thanks to all who helped! Above recommendations works.

    All works now.

    Recommendation: if you currently have vers 2.0 - PLEASE update to 2.0.3 or whatever is the most current. The WordPress Gods update these things for a reason ya know?

Topic Closed

This topic has been closed to new replies.

About this Topic