WordPress.org

Ready to get started?Download WordPress

Forums

Blog died after "nightly build" (12 posts)

  1. xrlq
    Member
    Posted 10 years ago #

    I tried installing yesterday's "nightly build," and now I can't view the blog at all. http://xrlq.com/ displays an error message:
    Warning: Compilation failed: nothing to repeat at offset 1 in /homepages/24/d88182035/htdocs/wp-blog-header.php on line 38
    Database error: [Unknown column 'post_date_gmt' in 'field list']
    SELECT DATE_ADD(post_date_gmt, INTERVAL '-14400' SECOND) FROM wp_xrlqposts WHERE post_date_gmt <= '2004-05-08 18:24:23' AND post_status = 'publish' ORDER BY post_date_gmt DESC LIMIT 1
    Database error: [Unknown column 'post_date_gmt' in 'where clause']
    SELECT DISTINCT * FROM wp_xrlqposts WHERE 1=1 AND post_date > '1969-12-25 19:00:00' AND post_date_gmt <= '2004-05-08 18:24:59' AND (post_status = "publish") GROUP BY wp_xrlqposts.ID ORDER BY post_date DESC
    Also, http://xrlq.com/wp-admin/post.php gets me a blank screen.

  2. NuclearMoose
    Member
    Posted 10 years ago #

    xrlq,
    This is just a shot in the dark, so forgive me if it seems too obvious...you did run wp-admin/upgrade.php after uploading the new files, correct?
    Craig.

  3. Root
    Member
    Posted 10 years ago #

    If I might politely intrude, and I say this for the benefit of all users, at this stage with 1.2 beta now being installed, it really helps the guys who know the answers,
    to know what version and build you are on. You seem possibly to have two errors. I have had the post_date_gmt error and Nuke is right. Running upgrade,
    regardless of the fact it was a new install did the trick.

  4. xrlq
    Member
    Posted 10 years ago #

    Actually, I hadn't run that. I just did. Now http://xrlq.com/ yields an Error 500. Going to the post.php file prompted a new login screen, but once I did log on, it was back to the blank one.

  5. xrlq
    Member
    Posted 10 years ago #

    And no, I'm not using the beta version. It's the latest build of Version 1.0.1. Though at this stage, I'd gladly upgrade/downgrade/sidegrade to whatever will work.

  6. xrlq
    Member
    Posted 10 years ago #

    Also, links to specific entries (e.g., http://xrlq.com/archives/2004/05/07/1489/the-joys-of-suv-ownership/#comments) also yield a blank screen.

  7. Matt Mullenweg
    Troublemaker
    Posted 10 years ago #

    It looks like you did not upgrade all the files correctly. Delete your old WP files, reupload all the files from a fresh download.

  8. xrlq
    Member
    Posted 10 years ago #

    I did, this time with the 5-8-04 build. Then I re-ran upgrade.php. No changes - still the same 500 error.

  9. xrlq
    Member
    Posted 10 years ago #

    Also, both times upgrade.php warned me it would take a while, but ran rather quickly before telling me everything was done.

  10. xrlq
    Member
    Posted 10 years ago #

    This time I moved everything to a separate directory, and tried installing from scratch. That got me this error message:
    "You appear to already have WordPress installed. If you would like to reinstall please clear your old database files first."
    If I clear the database, I'll lose approximately 1,500 entries. Are there any other alternatives?

  11. MaxT
    Member
    Posted 10 years ago #

    1) You rename all of your tables from wp_* to something_*
    2) You config your cfg properly to use not wp_ but somethingn else as prefix for your new tables
    3) You dump your database, save it somewhere, clean DB, test it... then import dumped sql file again back if needed
    http://www.MaxT.dk

  12. xrlq
    Member
    Posted 10 years ago #

    OK - I got the blog back. For some reason, I still got the 500 error when attempting to display, but once I logged in and posted a new message, the 500 error went away and the blog returned. Then I deleted the test entry and the 500 error came right back again. Go figure.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.