WordPress.org

Ready to get started?Download WordPress

Forums

Blog by email (4 posts)

  1. DenTom
    Member
    Posted 7 years ago #

    I'm using the blog by email option in WP.
    Everything is set correct, but when I send an email, WP only reads the sender email and the subject, but not the content of the message. Could anyone help me to solve this problem?

  2. YorchMtz
    Member
    Posted 6 years ago #

    I've been trying to find a fix, I'm using the 2.3.1 and I've seen the Ticket #4337 in the Trac.Wordpress Bu I have not results. iF someone could help please! :DD

  3. JaneLitte
    Member
    Posted 6 years ago #

    Is your email being sent in plain text or html/rtf. The stripping of the email contents happened to me when I was sending from Gmail, but when I changed the format to plain text, it showed up fine.

  4. llamaman
    Member
    Posted 6 years ago #

    I found the following solution, which fixed the issue for me:

    It looks as though multipart messages aren't being parsed correctly. I made a quick fix to wp-mail.php:
    Approx 165 lines in, you'll see:
    if ($content_type == 'multipart/alternative') {
    $content = explode('--'.$boundary, $content);
    $content = $content[2];
    $content = explode('Content-Transfer-Encoding: quoted-printable', $content);
    $content = strip_tags($content[1], '<img><p>
    <i><b><u><strike><font><span><div>');
    }
    Just change the line that reads:
    $content = explode('Content-Transfer-Encoding: quoted-printable', $content);
    into:
    $content = explode("\r\n\r\n", $content, 2);

Topic Closed

This topic has been closed to new replies.

About this Topic