WordPress.org

Ready to get started?Download WordPress

Forums

Blog by email (21 posts)

  1. J3r0m3
    Member
    Posted 10 years ago #

    I am using WP 1.2 right now.
    Tried out the email blogging yesterday at ard 1400hrs.
    So i sent the mail like the instructions and then i activated it by pointing my browser to /wp-mail.php
    and i got a message saying 1 messagge deleted.
    Thinking that all is done, i checked my blog, but i do not see anything.
    Logging in, i see that the post is there, but the timing is 0200hrs today.
    How do i rectify this problem?
    Is it my server's problem?
    How do i even check my server's time.
    My region is GMT +8
    server is from Siteflip

  2. somefool
    Member
    Posted 10 years ago #

    i get that, if you go into wp admin and edit, youll see the post there but you have to edit+save it for it to appear in the actual blog.
    no idea why.

  3. J3r0m3
    Member
    Posted 10 years ago #

    ok, will try it out first

  4. somefool
    Member
    Posted 10 years ago #

    it cant be right though, surely it should just go directly into the blog properly, rather than having to be 'approved'.
    anyone had any luck with the email blogging?

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    I am having the same exact problem as above myself.

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    Ran into a problem regarding the blog by email functionality. The only thing is, I know that my pop server works, as I use it all the time for my site. And as I run it myself, it's well known to me. I was getting an error stating that my server was not RFC1939 compliant or something very similar. However when I commented out the block including if($this->RFC1939) ... else and just had it return true it works fine now.
    I have it working and all, but any ideas on that?

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    I've noticed that, if I post via email, the post won't show up on the blog even though it's marked as "published" until I make it draft then published manually. The limitation seems to lie in the Slug - it's not set when I post via email and so it doesn't make an entry for it. Once something is filled into the Slug field, it posts just fine.
    This does make the Email Post feature rather less than useful, as it doesn't post by email. If you have to log into the blog to make the post visible, it removes the benefit of being able to email in your entries.

  8. Skit
    Member
    Posted 10 years ago #

    Ohh just noticed that the slug field actually has data and still the post isn't displaying :/

  9. Skit
    Member
    Posted 10 years ago #

    Worked it out. It's a timezone issue.
    The server is in GMT time.
    My local computer is in +0800 time.
    Emails sent are timestamped with the times 8hours fast.
    Wordpress then takes the time from the email and assumes it's in same time as the server. This is even with the Timezone settings in place for the blog with +0800 hours set.
    Setting my local pc time to GMT time then sending an email worked a treat.
    This has been tested with v1.2 and the nightly 28th May nightly build. Looking at the CVS logs, it looks like it a problem they've tackled a few times, hopefully it can be resolved.

  10. AndySocial
    Member
    Posted 10 years ago #

    Well, since my host is in Pacific Time and I'm in Central Time, changing my computer's clock every time I want to post by email is silly. Also, if I'm posting by email it will be through my work computer, which I can't change anyway.
    And, regardless, if I post by email I don't get a slug, so when it does post two hours later, the permalink is broken. I guess it's two separate issues.

  11. Skit
    Member
    Posted 10 years ago #

    Well at least the email timezone issue can be fixed by using the wordpress-2004-05-28 build from http://wordpress.org/nightly/. But i'm not sure what other problems this could cause using a non release version. :P
    For me, for now. I'm going to just use the 05-28 build and see what happens as the main reason for the blog is for remote posting for when I'm on hols and out n about. :)

  12. somefool
    Member
    Posted 10 years ago #

    I upgraded to the nightly build and i cant see any other differences in the time settings.
    Im in the UK and my servers in the US so I have to wait a few hours before they synchronise and the post becomes live.
    the only issue ive had with upgrading to the nightly build (apart from overwriting files i dont really want to - ie my css file - i wish it was easier to upgrade) the recentcomments and recent post plugins that i use from http://mtdewvirus.com/ need to have some code change ala http://wordpress.org/development/archives/2004/05/28/the-road-ahead/ and http://wiki.wordpress.org/1.3/TableVariables

  13. Skit
    Member
    Posted 10 years ago #

    No change in the Time Settings as far as I could see, but the change for this problem was code change in wp-mail.php. It now calculates the GMT and Blog site time better. :)

  14. somefool
    Member
    Posted 10 years ago #

    ah right, still doesnt work for me, must be something to do with the server being in USA and me (and the time of my posts) being in the UK.
    The other problem I have with the post by email is with email from my phone, which ends up with lots of extraneous characters in the title.
    Does anyone know how, of if theres a plugin/hack to post images with emails in emailed posts - does that make sense? I hope so.

  15. J3r0m3
    Member
    Posted 10 years ago #

    has anyone come up with a solution of the server time issue yet?

  16. Anonymous
    Unregistered
    Posted 10 years ago #

    I'm having the same errors listed above. I have all the email settings all set up, WordPress gladly retrieves my mail, but then will not publish it!
    What work-around can we do to get this thing to work? Any way of altering the script to actually put something into the 'Slug' field??

  17. mattmend
    Member
    Posted 10 years ago #

    I'm noticing that the standard wp-mail.php in 1.12 release doesn't delete the mail from my server after posting it (even though it says its deleted it). Any ideas?

  18. kirkio
    Member
    Posted 10 years ago #

    yeah, i had this problem, but when I let a cron job do all of the work

    GET http://www.myblog.com/wordpressdirectory/wp-mail.php

    it magically was fixed!

  19. sufehmi
    Member
    Posted 9 years ago #

    Thank you ... sms-wp-mail has enabled my WP (mingus / v1.2.1) to show posts that are posted by email.
    I suspect it didn't show up due to the timezone difference problem - which is fixed by sms-wp-mail.
    Thanks again !
    To anyone who missed it, you can download it from here:
    http://mookitty.co.uk/devblog/category/sms-wp-mail/

  20. yours
    Member
    Posted 9 years ago #

    I UPDATE CRON http://WWWWWWWW.COM/wp-mail.php
    IS IT OK.

  21. justinjoylife
    Member
    Posted 9 years ago #

    I know this may be a dumb question but in WP, can multiple users post via email and have the posts show up in realtime with the correct author?

    thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.