WordPress.org

Ready to get started?Download WordPress

Forums

Blog Broken (23 posts)

  1. luckylibra
    Member
    Posted 9 years ago #

    I am sorry to title this so oddly...but I honestly do not know how else to describe it...perhaps utter frustration and anger?

    I have somehow managed to change the characterset to UTF-7 instead of 8 and I think this is part of the problem.

    I seem to have broken something, as some of the charaters in posts are no longer appearing right...breaks in lines are not appearing right. When I click to edit on posts or comments, there is NOTHING there???

    I've tried to switch it back to the recommended 8, but it will not save the change. In fact, it won't save ANY changes I make...I am SO frustrated!!

    My blog is here: http://www.luckylibra.com/bloggy/

    Although the content of the second entry is not suitable for "everyone" its got the best example of text issues. A few down is a MEME that has lost its format...its all run together.

    Anything I click, any changes I try to make, they are not saving. It just bumps me to the "All Options" page, and even if I make the changes there...NADA!!

    Help....please...

  2. Cypher
    Member
    Posted 9 years ago #

    Are you by any chance running phpMyAdmin on your website?

    If so, great. If not, grab it and you can make the necessary changes to the database directly and fix your issues.

    You will need to edit the 'wp_options' field and on the second page, you will find an entry aptly named 'blog_charset' that needs to be set to "UTF-8".

    Hopefully whatever is ailing your blog will be fixed by this change.

    Regards

  3. luckylibra
    Member
    Posted 9 years ago #

    *wails*

    Not only can I not make any changes, add/activate/deactivate plug-ins...

    I cannot seem to get the dumb thing to even LOAD... *points*

    It says my config file is wrong???

  4. luckylibra
    Member
    Posted 9 years ago #

    OK, got the config issue fixed.

    Got the suggest application uploaded...not sure what to do with it.

    *sigh*

    And all I wanted to do today was post some pictures of my kid. Grrrr.

  5. Cypher
    Member
    Posted 9 years ago #

    Modify the file 'config.inc.php' in your phpMyAdmin directory with the necessary database username/password that you have in your 'wp-config.php' file.

    Just entering the username and password should be enough. Now when you go to http://yourdomain.com/phpMyAdmin (or wherever you installed it), you will see a nice graphical program. From the drop down menu, choose your WordPress database. You can gather the name from 'wp-config.php' again.

    Now, click on the 'wp-options' link in the left menu. From there, in the right window click on "Browse" to show you all the information stored in the 'wp-options' table. You should now to go the second page using the > button and look for 'blog_charset' optionname. Once you find the entry, "Edit" it, make the necessary changes and "Save" at the bottom of the page.

    Hope that gets you going.

    Regards

  6. vkaryl
    Member
    Posted 9 years ago #

    Just visited, looks fine to me in FF 1.0.4, no sign of what you describe....

    [Love the 2nd post btw - thankfully I'm all done with that! Some things to be said for aging....]

  7. Cypher
    Member
    Posted 9 years ago #

    That's strange, I see the problem on FF 1.0.4, Konqueror and Opera under Linux.

    Regards

  8. vkaryl
    Member
    Posted 9 years ago #

    Hmm. Yes, that's odd. The first time I clicked on her link, I got a database error message; just before I posted, I accessed her page for the first time and it's displaying just fine.

    I just went back, and while the "normal" posts are still displaying fine, the meme she mentions is appearing run together now instead of spaced.

    Strange....

  9. luckylibra
    Member
    Posted 9 years ago #

    Nutz

    #2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)

  10. luckylibra
    Member
    Posted 9 years ago #

    I put in the Database username and password

    I've got it at:

    http://luckylibra.com/phpMyAdmin-2.6.2-pl1/

    wrong file name?

    I suck...I know...

    I am sorry to be such a n00b

  11. Cypher
    Member
    Posted 9 years ago #

    You should essentially copy over the Username, Password, Hostname into your 'config.inc.php'. The error message seems to indicate you didn't provide a password for phpMyAdmin to login to the database.

    Regards

  12. luckylibra
    Member
    Posted 9 years ago #

    Thanks Cypher.

    I've got the file open in Notepad (didnt know what other program to edit it with).

    Its a huge long mess of coding that is greek to me. I am trying to find all of the places to change my password.

    I know the database name, username, password and host (same info that is in the WP config file). So I am not sure what the deal is.

  13. Cypher
    Member
    Posted 9 years ago #

    You wanna be editing the following three lines:

    On my version of the file (2.6.1-pl3)
    $cfg['Servers'][$i]['host'] - Line 69
    $cfg['Servers'][$i]['user'] - Line 84
    $cfg['Servers'][$i]['password'] - Line 85

    I removed the last entry from my phpMyAdmin configuration and got the same error message as you. So that is most likely the culprit.

    You can leave virtually everything else in the file unchanged.

    Regards

  14. Cypher
    Member
    Posted 9 years ago #

    Another piece of advice, when you are doing fixing your blog with this software, I would strongly recommend either password protecting the directory or removing your username/password from the config.inc.php file. Otherwise, ANYONE can get into the backend of your blog and do nearly anything they want.

    Regards

  15. luckylibra
    Member
    Posted 9 years ago #

    I understand...this is all so new to me...I'm on the verge of tears...as silly as that is.

    I think Ive fixed the password issue...now I've got a NEW error...

    The host name is empty!
    Warning: Cannot modify header information - headers already sent by (output started at /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/common.lib.php:1388) in /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/select_theme.lib.php on line 98

    Warning: Cannot modify header information - headers already sent by (output started at /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/common.lib.php:1388) in /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/index.php on line 55

    Fatal error: Call to undefined function: pma_dbi_get_dblist() in /home/.ballou/luckylibra/luckylibra.com/phpMyAdmin-2.6.2-pl1/libraries/common.lib.php on line 1458

  16. luckylibra
    Member
    Posted 9 years ago #

    I think I am gonna scrap it and do a clean install of this admin thing

  17. luckylibra
    Member
    Posted 9 years ago #

    Same problem

    Still cant get WP to allow me to make/save any changes.

  18. luckylibra
    Member
    Posted 9 years ago #

    I cannot get the phpAdmin program to work.

    I cannot get WP to save any changes. It wont let me fix where the UTF-7 is.

    It will not let me make any other changes either.

    As you can see by my blog, its screwed up. Not hugely.

    If I try to edit one of the entries (in an attempt to ignore the other WP issues), it opens up the edit screen, but there is NO text present.

    I am now considering whacking it altogether and completely redoing the install of WP, but I dont want to lose my posts.

    I've been sitting here for 6 hours...I am green...I dont know what i am doing, I dont know what PHP does, or how it works. I am lucky I can hand code a bit of HTML.

    I really just want to start all over...but I don't know how to save the last year of posts...

  19. If you want to edit the files, they need have permissions set to 666 (CHMOD 666). See: http://www.tamba2.org.uk/wordpress/ftp/

    Alternatively, you could download the offending files, edit them with a plain text editor, and upload the edited copy. See: http://codex.wordpress.org/Glossary#Text_editor

  20. luckylibra
    Member
    Posted 9 years ago #

    Blog Fixed.

    Many thanks to those that listened to me whine, if you will excuse me, I need to go pass out...

  21. Cypher
    Member
    Posted 9 years ago #

    Looks great, glad you got it fixed and came out largely unscathed..:)

    Regards

  22. EricN1023
    Member
    Posted 8 years ago #

    I can't login at wordpress.com. It always says that my password is incorrect and asks me if my cookies are enabled, which they are. This is really bugging me and I am a first time user.

Topic Closed

This topic has been closed to new replies.

About this Topic