WordPress.org

Ready to get started?Download WordPress

Forums

Blog all messed up in Firefox (3 posts)

  1. oyvindronning
    Member
    Posted 7 years ago #

    Hi,

    I recently uploaded the WP blog system to my site and it worked great - thanks!

    Although it seemed to go very smoothly, something went wrong. After I added a YouTube video (using the embed code) the site went crazy in Firefox. Take a look here. Make sure you're using Firefox.

    I find it really strange that the whole site goes wild after adding that small thing, but I know that's what causing it because I tried to delete/repost et cetera.

    I searched and found several threads on YouTube problems with WP and similar topics, but no one had the same problem as me. I read that it might work when turning off the rich editor and I tried that, but no luck.

    It would be nice to have some Firefox visitors so please help me. Cheers!

  2. dankeebs
    Member
    Posted 6 years ago #

    I know you posted this 4 months ago. Hopefully you've found a solution to the YouTube problem by now. Cuz that's what I'm dealing with at the moment.

    Exactly the same thing. I raed your post and thought "Wow, he is describe the past 2 hours of my life...read other posts...tried suggestions...didn't work...blah"

    Any luck 4 months later?

  3. dankeebs
    Member
    Posted 6 years ago #

    Okay I pinpointed the problem and the steps to it. I'm not a technical dude, so anyone who is, do what you do with this info.

    When you try adding a YouTube video's Embed code this is what happens...

    In 3 easy steps

    Step 1 - Embedding code in "Code" view.
    image 1

    Notice that the first tag, which is an "object" tag does NOT close right after the opening tag. This is good.

    Step 2 - Adding your text content before and after the YouTube video object.
    image 2

    Step 3 - Vwala! Presto Chango! Blog gone nuts in Firefox!
    image 3

    That first Object tag "magically" now has a closing /object tag!

    This is the culprit that screws up your whole blog, as seen in this final image.
    image 4

    If you delete that closing /object tag, everything will look normal in Firefox.

    Also, if you just embed the YouTube video without adding text around the video, that /object tag will not magically appear.

    The only solution I've seen is to disable the WSIWYG/Rich Text editor. Go to "Users" at the top of your dashboard > "Your Profile" > and uncheck the "Use the visual editor when writing" box.

    This will stop the magical appearance of the /object tag, but will also prevent you from viewing the post as your write it. Basically, you're writing in the "Code" tab only.

    Hope this gets fixed. Not sure how to properly inform the WordPress engineers. If you know how, please pass it on to them.

Topic Closed

This topic has been closed to new replies.

About this Topic