WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] blog address in header 404 error (7 posts)

  1. cmenke
    Member
    Posted 7 years ago #

    I have wordpress installed in it's own directory and something seems to have changed since my recent installation. Initially, the link to the index page from the header worked fine but now it does not.

    To be short and sweet, this works:
    http:www.mydomian.com/blog/index.php

    but the way the header forms the URL does not work:
    http:www.mydomiain.com/blog/index.php/

    With IE this gets me a 404 error and in FF, the header, sidebar and footer show up but the content gets a 404 error. Any hints on what I messed up in the .htaccess file (maybe) or some other server configuration (it's running on a linux server) or a fix for the address in the header file would be appreciated.

  2. krugern
    Member
    Posted 7 years ago #

    remove index.php from the url.

    only use http:www.mydomain.com/blog :)

  3. cmenke
    Member
    Posted 7 years ago #

    Thanks, I've actually already spent time looking at how to do that. That address, though, (http:www.mydomiain.com/blog/index.php/) is where you are taken when you click on the header text and that link is created during the install. I looked for what file actually tells the header what the URL of the index page is but I haven't been successful.

  4. Chris_K
    Member
    Posted 7 years ago #

    but the way the header forms the URL does not work:
    http:www.mydomiain.com/blog/index.php/

    Nor should it. ever.

    Options -> General what do you have for the two URI values?

    If you know where the code is in your theme files (like header.php or index.php) that makes the clickable image is, it would be nice to see the small snippet in question.

  5. cmenke
    Member
    Posted 7 years ago #

    In the "Options -> General" page, the URI shows without the forward slash like this:
    http:www.mydomiain.com/blog/index.php

    In the header.php file, I think this is what calls for the information to create the link address (but I'm not a programmer so I'm not sure. This is the default theme)


    <div id="header">
    <div id="headerimg">
    <h1><a href="<?php echo get_settings('home'); ?>/"><?php bloginfo('name'); ?></a></h1>
    <div class="description"><?php bloginfo('description'); ?></div>
    </div>

  6. Chris_K
    Member
    Posted 7 years ago #

    Remove index.php from those links in Options -> General and you should be fine. So just
    http://www.mydomiain.com/blog/

  7. cmenke
    Member
    Posted 7 years ago #

    cool. thanks

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags