WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
[resolved] BlockUI alert! (33 posts)

  1. ameraz
    Member
    Posted 1 year ago #

    A very annoying javascript alert is comming up in all my WooCommerce sites as of yesterday. It says:
    blockUI requires jQuery v1.3 or later! You are using v1.10.0

    Problem is that if I update to a newer version of jQuery plugins start to thorw errors.

    Any recommendations on how to make it compatible:

    Site in question:
    http://riverogonzalez.com.mx/

    http://wordpress.org/extend/plugins/woocommerce/

  2. Lidren
    Member
    Posted 1 year ago #

    This ^

  3. claudchan
    Member
    Posted 1 year ago #

    I got the same issue here.

  4. Cresencio Cantu
    Member
    Posted 1 year ago #

    I had this same issue after updating WooCommerce. I reverted back to ver 2.0.5 and I'll keep it that way until someone can provide a better solution

  5. nonick80
    Member
    Posted 1 year ago #

    Solved.

    1. Go to https://github.com/woothemes/woocommerce/tree/master/assets/js/jquery-blockui

    2. Download the 2 js files. Make sure that the file extension remains as .js after you've downloaded them. My firefox turns them into .js.htm files. If that happens, manaully remove the ".htm" in the file name.

    3. Use your ftp or control panel, go into folder where woocommerce stores the 2 js files.
    i.e. wpcontent / plugins / woocommerce / assets / js / jquery-blockui

    4. Backup the 2 files in the folder

    5. Overwrite the 2 files with the ones you just downloaded.

    Refresh you site. The annoying message should go away. :)

  6. nonick80
    Member
    Posted 1 year ago #

    Realized that the files for github will somehow cause some problems with the variations in the product post.

    So I loaded back my original backup.

    Edit the 2 original files jquery.blockUI and jquery.blockUI.min by removing the command below in both files (make sure you backup first):

    alert('blockUI requires jQuery v1.3 or later! You are using v' + $.fn.jquery);return;

    Do not delete the {} at the front and back of the command though.

    That stopped the annoying alert on the webpages and then the variations will still work! :)

    Until woocommerce come up with a fix....

  7. mike1394
    Member
    Posted 1 year ago #

    I found this article that helped me. Hope it helps someone else.

    http://ideasandpixels.com/blockui-requires-jquery-v1-3-or-later-quick-fix

  8. metalmusicman
    Member
    Posted 1 year ago #

    I was also getting the BlockUI error after updating to WordPress 3.6, it looks like WooCommerce was the culprit.

    Removing "alert('blockUI requires jQuery v1.3 or later! You are using v' + $.fn.jquery);return;" (but not the "{" or "}" as nonick80 mentioned) fixed it for me.

    The files I needed to remove the line of code from were:

    .../woocommerce/assets/js/jquery-ui.js
    .../woocommerce/assets/js/jquery-ui-min.js

    and

    .../woocommerce/assets/js/admin/woocommerce_admin.js
    .../woocommerce/assets/js/admin/woocommerce_admin.min.js

    Thanks for the tips and I hope my post and the rest here have helped people.

  9. Sebastien D
    Member
    Posted 1 year ago #

    Can the files be changed to only load on the required pages for WooCommerce and not every page in the admin please.

  10. studio34
    Member
    Posted 1 year ago #

    Same issue. WooCommerce is the culprit.

  11. webowner
    Member
    Posted 1 year ago #

    I don't have woocommerce - and yet still see this error message.

    How do I get rid of it? Just upgraded to WP version 3.6

  12. webowner
    Member
    Posted 1 year ago #

    Not: Woo Commerce

    And am having trouble identifying which plugin is causing it...

    How do I find it?

  13. msshoffman
    Member
    Posted 1 year ago #

    no Woo Commerce here either. Just upgraded WP to 3.6 and get error message
    blockUI requires jQuery v1.2.3 or later! You are using v1.10.2.

  14. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

  15. webowner
    Member
    Posted 1 year ago #

    Thank you WPyogi... I did see that post earlier... But, I'm not sure WHERE to replace the jqueryui file...

    Any thoughts?

  16. Sebastien D
    Member
    Posted 1 year ago #

    I'm getting the same error on the front also. Didn't notice until just now. So since upgrading WordPress we now have to change a jQuery file. Can't WordPress just correct this and release a quick update ?

  17. msshoffman
    Member
    Posted 1 year ago #

    I was able to fix mine. I did a search of my files (from a recent backup) and found the jquery.blockUI file in All in One Event Calendar - which was supposedly up to date. I tried to install the latest version without uninstalling the old but no such luck. Once I deleted the old version and installed the new the error message went away. Unfortunately I lost all my events but most were PAST with only a few upcoming so it wasn't too bad.

    Hope this helps :)

  18. Sebastien D
    Member
    Posted 1 year ago #

    I am not seeing the jquery blockUI file in my source code. What is the exact name of the file ?

  19. NormanBird
    Member
    Posted 1 year ago #

    I had same issue and saw many solutions to this bug. In the end I went with searching my wp-content folder for files with CONTENT:

    alert('blockUI requires jQuery v1.3 or later!

    this was in one file in the woocommerce plugin directory called:
    jquery.blockUI.js (so search for *.* not just .php)

    I found the file and the line it was on and simply commented it out with /* */

    There was also a indemnified version of the same file which I had to search for and comment out also.

    blessings

  20. msshoffman
    Member
    Posted 1 year ago #

    Sebastien - search for "jquery.blockUI" in your site files - it was in my backup I did prior to upgrading to WP 3.6 - once I saw what folder it was in I was able to figure out which plug in was the culprit.

  21. gezginrocker
    Member
    Posted 1 year ago #

    For me the responsible plugin was Anthologize. I disabled it and message doesn't appear anymore.

  22. msshoffman
    Member
    Posted 1 year ago #

    ok so key is figuring out which plugin is culprit and go from there I think!

  23. marom
    Member
    Posted 1 year ago #

    Thanks gezginrocker, deactivated Anthologize and all good :-)

  24. hamergil
    Member
    Posted 1 year ago #

    Hi Guys
    Just update your woo commerce plugin.
    I Just updated my woo commerce plugin today and the alert is gone.

  25. jameskoster
    Member
    Plugin Author

    Posted 1 year ago #

    Marking as resolved.

  26. Vince
    Member
    Posted 1 year ago #

    Guys, try http://wordpress.org/plugins/jquery-updater/ I just installed this one and then activated it and that nasty block warning of jquery is gone.

  27. Bruno Cassoni
    Member
    Posted 1 year ago #

    look for this iframe in page (plugins/woocommerce/assets/js/woocommerce.min.js)

    <iframe class="blockUI" style="z-index:'+t++ +';display:none;border:none;margin:0;padding:0;position:absolute;width:100%;height:100%;top:0;left:0" src="'+h.iframeSrc+'"></iframe>

    and delete this.... problem resolved.

  28. medesis
    Member
    Posted 1 year ago #

    Hi Guys,

    This is all really helpful, but my problem is when I try to open the .js files that need editing they appear for a flash of a second and disappear again so I can't edit them. I'm using filezilla - any help much appreciated.

    Thanks

  29. davidjs
    Member
    Posted 1 year ago #

    Wp-includes > js > jquery > jquery.js there is a commented out title that has the 1.10 just change it to 1.9 yes this is hacking the core of wordpress but its a super easy fix, when 1.11 comes out in an update you wont have issues again.

  30. elevenmidia
    Member
    Posted 1 year ago #

    davidjs
    Man congratulations!

    This was the best solution for blockUI with only 2 buttons I found.

    Saved the night. All my themes are gone show message after the update.

    Thank you ....

    Can close the topic, thanks to "davidjs" above.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic