WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blockquote Problem (9 posts)

  1. technguide
    Member
    Posted 1 year ago #

    Hello people, i have this strange problem and i can't seem to understand why this is happening. So this is the problem here. My blockquote seem to be overflowing vertically.

    Which part of the style.css do i need to edit?

    Here's an example on my site.

  2. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    You need to start with these error, http://validator.w3.org/check?verbose=1&uri=http%3a%2f%2ftechnguide.net%2f%3fp%3d5255 especially the ones caused by the code in front of DOCTYPE. DOCTYPE has to be the first item in your source code.

  3. mrspabs
    Member
    Posted 1 year ago #

    Go to your style.css and remove height: 100%; from the blockquote

  4. technguide
    Member
    Posted 1 year ago #

    @mrspabs Yes! That fixed the problem. Thank you very much!

    @kmessinger that is the tool i was looking for. I ran the tests on some of my blog posts. I found a lot of errors. How do i correct them. Some of them like '</p>' exists without '<p>'. I checked my HTML code for each posts and didn't find any '<p>' or '</p>' used. So i reckoned it should be the theme's files problems. Could you point me in the right direction as to where i should start finding the error roots?

  5. kmessinger
    Volunteer Moderator
    Posted 1 year ago #

    Here is a check showing the source code also, http://validator.w3.org/check?uri=http%3A%2F%2Ftechnguide.net%2F%3Fp%3D5255&charset=%28detect+automatically%29&doctype=Inline&ss=1&group=0&verbose=1&user-agent=W3C_Validator%2F1.3 so you can see the line the error was on.

    If you are putting html into the editor, it will change things that it thinks are wrong. If you hit enter between lines you will see no code but after it is published you will find the editor has added the <p>.

  6. If you remove height: 100% in your style.css and I don't remove it in theme style.css, next time you update the theme, it will be there again. And that's not good:)

    @technguide: could you point out which browser that happened? And url where this happens. I can't replicate that issue in any of browsers that I'm testing.

    You have this weird script before DOCTYPE. It doesn't come from the theme. I guess it's coming from a plugin.

    <script>
    	//location = "/construction/";
    </script>

    What comes to Validators, use HTML5 DOCTYPE. And even after that Validators pick up a few 'errors'. Link is more like this. I don't think there are any bugs in theme template files, but please let me know if there are.

    And I encourage you to install and activate child theme just in case you make even one modification.

    http://themehybrid.com/themes/path-child

    http://codex.wordpress.org/Child_Themes

  7. To be clear: height: 100% was for IE7 and I can take it off, because I'm not supporting that browser anymore.

  8. technguide
    Member
    Posted 1 year ago #

    Hi @Sami Kelijonen, I'm already using the Child Theme.

    I'm using Safari Version 6.0.1 (8536.26.14). I've fixed that problem now, i will replicated this blockquote problem on this website. [That's strange, i can't seem to replicate this issue anymore.]

    What i did in my main blog is i replace the style.css on the child theme with the edited version [just to remove that height: 100%;] copied from the parent theme. Did i do anything wrong?

    Thanks everyone for trying to help!

  9. technguide
    Member
    Posted 1 year ago #

    Thanks anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic