WordPress.org

Ready to get started?Download WordPress

Forums

Blocked Port 80 Redirect Breaks Comments (6 posts)

  1. xadrian_calim
    Member
    Posted 7 years ago #

    Hiya. I had to move ISPs and the new one blocks port 80. I'm running no-ip to my own server. No-ip has a redirect so I can pick a new port. My DNS name resolves to an IP which is visible in the URL (not terribly happy with that, but...)

    Point is, so far everything runs fine except the comments and I'm not sure why. It's trying to open the wp-comments-post.php but it's just a blank page. I haven't changed any directory structure or files, just router and DNS settings.

    Any ideas?

  2. xadrian_calim
    Member
    Posted 7 years ago #

    Bit of additional info. No-ip.com has a Mask URL option so if you have to redirect port 80, it'll mask it to the site DNS name. Problem is, my style sheets don't work if I do that. Doesn't fix the comments either.

    I found an ealier post about someone with the same problem, but it was from a year ago and so far I haven't heard from direct contact with them.

  3. xadrian_calim
    Member
    Posted 7 years ago #

    More info. Sorry to keep bumping this, but aside from hosting the site elsewhere I haven't found anything pertaining to this issue (surely I'm not the only one am I?)

    Anyhoo, I've also found that even though I have the send referrals set to 2, each time I try to make an administrative change I'm prompted that it's not set. I found this because I've lost my WYSIWYG editor. Knowing I have a few plugins that could affect that, I went to disable them to trouble shoot. It wouldn't let me (send ref.)

    I also notice the page on the editor never fully loads so I checked my error console and saw a bunch of exceptions and this error:

    Error: uncaught exception: Permission denied to call method Location.toString

    So, basically I'm at the point where I can make new posts and edit the php (stylesheets, index, sidebar, etc), but I can't edit pages as the editor won't load and the page won't save and I've lost some admin abilities (link/user management) until I can get the send referral fixed.

    I'm pretty sure it all ties back to the DNS resolving to a port 80 redirect that resolves to the IP. I think the PHP is looking for the domain name and having it as the IP messes it up. But if I mask it, the style sheet isn't active.

    I have to be the only one running my own server with no-ip with a port 80 redirect and WP 2.0 on IIS 6, don't I...

    *sigh*

  4. xadrian_calim
    Member
    Posted 7 years ago #

    I'm terribly frustrated, I've read all the articles on "sending referrals" and I still can't get it working. I can't make any changes to my site save for writing new posts.

    Sorry, you need to enable sending referrers for this feature to work.

    It's set to 2 in firefox, then set to 1, then back to 2. The I try in IE with it listed in trusted sites. I don't have Norton even installed. I'm really close to hosting this elsewhere so the IP redirect isn't screwing it all up, but surely there's help to be had, yes?

  5. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    I'm pretty sure it all ties back to the DNS resolving to a port 80 redirect that resolves to the IP.

    That's not how that sort of thing actually works.

    Your domain resolves to one of no-ip's server's, which then sends a redirect to your real IP. Which, naturally, screws with your referrer infos.

    The only way to fix this is to change the WordPress and Blog URL's on Options->General to be your *real* address, and not your domain name. You won't like the result though, as your IP will be shown in the address bar. WordPress just does not play nicely with redirects. Masked redirects are even worse, as they use a frame deal to mess with this sort of thing.

    Long term, I suggest to stop self-hosting if you cannot serve on port 80. Get a hosting provider. There's some free ones out there, and there's some quite affordable ones as well. I like GoDaddy hosting so far.

  6. xadrian_calim
    Member
    Posted 7 years ago #

    I do plan on hosting at godaddy, I just have to wait for some "disposable income." I mean, it's not much for what I need, couple bucks a month.

    And my IP already shows up in the URL from the redirct, so I'll go ahead and try that.

    Thanks for the response!

    The irony is, I'm unable to change the URI to the IP, it gives me a "send referral" error. Funny huh?

Topic Closed

This topic has been closed to new replies.

About this Topic