WordPress.org

Ready to get started?Download WordPress

Forums

Blaskan theme and Chrome, unable to click any links (11 posts)

  1. trench
    Member
    Posted 7 months ago #

    Hi. I'm using WordPress 3.81 with the Blaskan theme 2.64. '

    In Chrome on Windows 7 I am unable to click on any links such as the login link.

    My site is http://madmolesters.com/

    FF and IE work fine.

  2. Andrew
    Forum Moderator
    Posted 7 months ago #

    Where's the login link?

    Edit: NVM found it.

    Can you try clearing your browser's cache?

  3. trench
    Member
    Posted 7 months ago #

    I've cleared the browser cache several times and still no luck.

  4. Andrew
    Forum Moderator
    Posted 7 months ago #

    What version of Chrome are you using?
    Can you try disabling all of your Chrome addons?

  5. trench
    Member
    Posted 7 months ago #

    Version 32.0.1700.107 m

    I disabled all the extensions and still can't click most links.

  6. Andrew
    Forum Moderator
    Posted 7 months ago #

    Sorry I can't experience your issue on that version of Chrome.

  7. trench
    Member
    Posted 7 months ago #

    No problem.

    It works fine in Ubuntu with Chrome so hopefully it's just my Win 7 install.

  8. ShaunG
    Member
    Posted 6 months ago #

    I am experiencing the same problem. Apparently it is related to "touch events" and only occurs on touch enabled laptops and google chrome (not having the issue in IE)

    Do you have a touch screen laptop? Try tapping the link instead of clicking.. for me that works, but i don't expect my users to do this so until there is a fix unfortunately I am going to switch from this theme to another.

    See this post: http://wordpress.org/support/topic/links-wont-open-with-left-click?replies=6

  9. ShaunG
    Member
    Posted 6 months ago #

    Okay, I actually really like this theme so I decided to track the bug.

    The issue is caused by the mobile boilerplate helper functions recognizing Chrome on touch enabled devices as a mobile browser/tablet.

    The fix is simple:

    1. open this file: /yourblog/wp-content/themes/blaskan/js/mylibs/helper.js

    2. search for: MBP.scaleFix

    you will see this:

    MBP.scaleFix = function () {
      if (MBP.viewportmeta && /iPhone|iPad|iPod/.test(MBP.ua) && !/Opera Mini/.test(MBP.ua)) {
        MBP.viewportmeta.content = "width=device-width, minimum-scale=1.0, maximum-scale=1.0";
        document.addEventListener("gesturestart", MBP.gestureStart, false);
      }
    };

    3. You can choose to comment out these lines, or delete them. I deleted them.

    After deleting them, clicking now works. Tested responsiveness in Google Chrome and IE -- seems to work ok. Also tested from my Windows Phone and it appears to be functioning normally.

    Hope this helps.

  10. trench
    Member
    Posted 6 months ago #

    Thanks. No, it's just you're ordinary laptop.

    I deleted that snippet of code you mentioned and still getting the error however that may be because of the caching plugin my host forces me to use. I'll try to check back later. So far no reader has complained.

  11. ShaunG
    Member
    Posted 6 months ago #

    Oh ok, I will try to reproduce your error using my non-touch laptop and get back to you!

    In the meantime, perhaps you can try a solution mentioned in this thread: http://wordpress.org/support/topic/links-not-working-in-google-chrome-but-work-with-all-other-web-browsers?replies=16

Reply

You must log in to post.

About this Topic