WordPress.org

Ready to get started?Download WordPress

Forums

Blank wp-comments-post.php page when commenting on numerous WordPress blogs. (10 posts)

  1. zigojacko
    Member
    Posted 3 years ago #

    I comment on a lot of blogs day to day and I find that on over half of WordPress blogs I comment on, after clicking submit, I just get taken to a blank wp-comments-post.php page.

    As it happens on so many blogs, I am concerned that the issue may lie with me as opposed to a mis-configuration with that particular blog.

    What reasons would cause the blog comment not to submit?
    Would my comment still have been received in the back end of the blog?
    Is it possible my IP is blacklisted in some way?

    Any feedback on this would be greatly appreciated, there is nothing worse than spending half an hour writing an in depth reply on a blog only for it to display a blank page when I submit it.

    Thanks.

  2. zigojacko
    Member
    Posted 3 years ago #

    Can anyone from WordPress please respond to this as the issue is driving me insane. Thanks

  3. zigojacko
    Member
    Posted 3 years ago #

    So much for the support!

  4. We're all unpaid volunteers here who give up our free time to support thousands of users every day.

    Not everyone can help in every case.

    If you're encountering a blank wp-comments-post.php page when commenting, more than likely the problem is on the site that you're commenting on.

    Honestly, there's really no way to tell without contacting the blog's administrator.

    If you're concerned that you're being caught as spam, you could contact Akismet's support department at http://akismet.com/contact/

  5. zigojacko
    Member
    Posted 3 years ago #

    Hi James,

    Many thanks for the response - Sorry I thought that WordPress actually have employees on this support forum.

    I too, would have thought the issue would lie with the blogs themselves but I other people have posted on these blogs a matter of hours or a day before when I try so it seems a bit coincidental that the blog suddenly messes up when I try to comment.

    It's happening on loads as well, a good 4 or 5 at least out of every 10 WP blogs I might comment on only take me to a blank wp-comments-post.php page.

    I checked if my IP is blacklisted on this site http://whatismyipaddress.com/blacklist-check and it was fine on every server but maybe I should query with Akismet as well then.

    Thanks

  6. flybishop
    Member
    Posted 3 years ago #

    I'm getting this same error. I've sent a request to Akismet to see if I'm wrongly being blocked as spam, and I'll let you know if this helps for me.

  7. dscottS3
    Member
    Posted 3 years ago #

    I was getting a blank page after posting a comment as well. What fixed my issue was I had to change the form action in the theme to support https rather than http. Some themes I am using doesn't use the default comments function to display the form. So, I added the following to the form action:

    <?php echo site_url( '/wp-comments-post.php' ); ?>

    Instead of

    <?php echo get_option('siteurl'); ?>/wp-comments-post.php ?>

    After realizing that I have too many "broken" themes to update I created a file called update_siteurl.php and added it to my mu-plugins directory with the following code:

    <?php
    function update_siteurl() {
    update_option('siteurl',site_url());
    update_option('home',site_url());
    }
    ?>

    Hope this helps. Im running 3.0.4 multi site.

  8. Kchun
    Member
    Posted 3 years ago #

    I commented this out in wp-comments-post.php

    /*} elseif ( !$status_obj->public && !$status_obj->private ) {
    	do_action('comment_on_draft', $comment_post_ID);
    	exit; */

    [Please post code snippets between backticks or use the code button.]

    And now I see the comments. I'm running 3.0.5

  9. nveid
    Member
    Posted 2 years ago #

    I did a variation of that for my onlineforextradingtoday.info blog,
    basically I followed the instructions from this post(last comment on it) http://wordpress.org/support/topic/commenting-on-draft-posts?replies=2 .

    Basically what it suggested was similar to yours except rather than commenting it out changing the comment_on_draft to the following:
    do_action('pre_comment_on_post', $comment_post_ID); and then removing the exit; right after it.

  10. Cloudydays
    Member
    Posted 2 years ago #

    Hi, I'm having that problem on my blog when trying to make a test post and have been hunting down a solution to it. It's not a problem with your posting usually, it's a problem with the blog itself so don't worry yourself about it.

Topic Closed

This topic has been closed to new replies.

About this Topic