WordPress.org

Ready to get started?Download WordPress

Forums

blank wp-comments-post.php error (19 posts)

  1. marfisa
    Member
    Posted 7 years ago #

    Sorry, I know there are other posts by this title, but either the topics are already closed, or it doesn't really help with my problem.

    First of all, I'm using WordPress 2.1 and testing in both Firefox and IE. I'm not using any plugins at all and I've already tried switching themes.

    After upgrading to 2.1 (sorry, I don't remember what the previous version was), no one can make any comments on my posts, they just get taken to a blank page (wp-comments-post.php).

    I tried a completely fresh test install in another directory and it worked perfectly. But as soon as I moved the old database into the test site (after changing the 2 urls under wp_options), it has that error again and I can't post comments. So I'm sure the problem must be somewhere in the database, but I don't know what I should be looking for. Does anyone have any ideas?

    This is the currently broken test site-
    http://rahenna.com/loltest/

    And the currently broken real site-
    http://rahenna.com/journal/

  2. marfisa
    Member
    Posted 7 years ago #

    Oh, if anyone wants the broken database info to mess around with, I can e-mail it to you.

  3. philsagal
    Member
    Posted 7 years ago #

    Just an FYI...Since I tried to upgrade to 2.1, I have been having this same issue as well at http://www.sfgirlinparis.com.

  4. Samuel B
    moderator
    Posted 7 years ago #

    I'm assuming you deactivated all plugins before the upgrade?
    If not, do so now and reactivate them one by one, testing in between. Fairly sure you'll have one that's not upgraded for 2.1.

  5. philsagal
    Member
    Posted 7 years ago #

    Samboll,
    When I attempted to deactivate my only plug-in, the WP Database Backup, I received this error:

    "Sorry, you need to enable sending referrers for this feature to work."

    on this URL:
    http://sfgirlinparis.com/wp-admin/plugins.php?action=deactivate&plugin=wp-db-backup.php.

    I am not currently on 2.1 because I reinstalled (retrieved) my old files.

    Please let me know whether I should stay on Marfisa's thread or start my own. Don't want to draw attention away from someone else's issue.

    Thanks.

  6. marfisa
    Member
    Posted 7 years ago #

    Samboll,

    Neither of my sites are using plugins at all. The real site never used any and the test site was a fresh install.

  7. thellon0
    Member
    Posted 7 years ago #

    i'm having an identical issue. I started a topic of my own but realized that I did have the same problem as someone else.

    I just switched to 2.1 (and also switched to the "tarski" theme) but my comments don't work under any theme. I have tried deactivating all my plugins and it doesn't help the issue.

    Any ideas?

    Here is my site:
    http://www.thelongprocess.com

  8. dbasulto
    Member
    Posted 7 years ago #

    do you have the hidden field:

    
    <input type="hidden" name="comment_post_ID" value="1" />

    in your comment.php or single.php from your theme?

  9. thellon0
    Member
    Posted 7 years ago #

    I don't have a comment or single file in my theme directory. I do have a a 'comments' file in my theme, and also a 'comment.php' file in my wp-admin directory.

    Also, the comments don't work under any theme. Should i assume it's not a theme issue and a wp issue?

  10. Tony2Nice
    Member
    Posted 7 years ago #

    Same issue. Hope we get an answer soon. :)

  11. thellon0
    Member
    Posted 7 years ago #

    Does anyone know if there's a way to bring higher priority to this issue, or some way to flag a topic?

    This seems to be a growing problem with no solutions as of yet...

  12. jkeyes
    Member
    Posted 7 years ago #

    It seems like this has been hanging around a long time. I noticed on one of my blogs that disabling Akismet resolved the issue, but I know that isn't the problem here and isn't the problem that many others are encountering.

    If someone of the dev team could suggest a good way to debug this it'd be helpful.

  13. marfisa
    Member
    Posted 7 years ago #

    I have this line in comments.php, but I couldn't find anything in single.php-
    <input type="hidden" name="comment_post_ID" value="<?php echo $id; ?>" />

    Should that line be something else?

  14. marfisa
    Member
    Posted 7 years ago #

    I figured out a solution that finally works! Sorry if it's rather drastic.

    Export all your database tables except for wp_users, wp_usersmeta, and wp_options and save it as a file.

    Then delete your whole database and uninstall wordpress. Reinstall wordpress so that it creates all new data in the database. Test this to make sure the comments work.

    Lastly, import the database tables (minus users, usersmeta, options) from your old database. All your posts and comments and everything should be restored, except that you'll probably have to tweak all your settings again.

    So, the problem is in one of those three tables, but I couldn't find it. I hope this helps everyone.

    I won't mark this as resolved in case someone else figures out a better fix or this doesn't work for everybody.

  15. miglimey
    Member
    Posted 7 years ago #

    I had the same problem for about a week. Unfortunately for every post in here with this problem there is a different solution. Here is what fixed it for me...
    check that the wp_comments_post.php file contains code. Mine didn't. I checked my original WordPress files, and re-uploaded the wp_comments_post.php file. That fixed it. Don't foget to set the correct file access value (666 or 777)

  16. waydomatic
    Member
    Posted 7 years ago #

    I'm experiencing this bug myself.

    I build my sites locally (including all content), then upload a fresh install of WordPress. I then import all of the data from my local install.

    Strangely, I'm getting different results in different instances.

    http://www.mountain-living.com/ has the bug, but http://stage1.fourthwall.com.au/ does not. They are both fresh installs of WP2.1, and both have identical data in their databases. Both are hosted with DreamHost.

  17. waydomatic
    Member
    Posted 7 years ago #

    OK - this was the cause of my problem:

    http://plugins.baptiste.us/wordpress/blank-pages-when-posting-comments-in-wordpress/

    Everything's working perfectly for me now.

  18. alex94040
    Member
    Posted 6 years ago #

  19. Cobbi
    Member
    Posted 6 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags