WordPress.org

Ready to get started?Download WordPress

Forums

blank wp-admin pages on new install HELP (12 posts)

  1. austinc
    Member
    Posted 7 years ago #

    For starters, I've found several posts on this topic and have tried several of the suggestions, but nothing has worked.

    My problem; I did a new install of WordPress yesterday on my companies server, everything went well except that after I log into wp-admin everything is blank (only white space). When I view source on the blank page, all i get is this <?xml version="1.0" encoding="us-ascii" ?>. I can view the pages of the blog but not the wp-admin pages. http://www.earthsky.org/blog/

    Like I said earlier, I've tried many of the suggestions on other post with a similar problem. The following is some of the things I've tried:

    Deleted Extensions
    Deleted Themes
    Re-installed WP-Admin
    Re-installed WordPress
    Installed Older Version of WordPress
    Installed Lighter version of WP-Admin via Dashboard Hack
    Checked to make sure that index.php was in httpd.conf

    I'm new to working on this web server and I fear that they might have some weird server configurations. One thing that I noticed is that the root directory is 4 folders deep example: /var/www/earthsky/htdocs/ .

    Any ideas or help would be much appreciated it.

  2. geoffe
    Member
    Posted 7 years ago #

    the depth of your root directory is not a problem.

    Strangely, http://www.earthsky.org/blog/wp-admin/index.php is returning <?xml version="1.0" encoding="us-ascii" ?> while it should be directing to the login page.

    Trouble could be that the site url in your database is incorrect. If you're certain that the WP files are current and not compromised, clean out the database and go through the install process again to reset the DB values. It will contain details of extensions to load and directory info that could be causing this.

    Abandon those other fixes and use a clean install.

  3. austinc
    Member
    Posted 7 years ago #

    Thanks Jeff. I wiped out the data base and deleted WP from the blog folder. I then re-setup everything, however, I didn't see "details of extensions to load and directory info". Should that have been in MYSQL or WP setup? Never-the-less, the clean install still has the same blank page problem. Have any other suggestions?

  4. geoffe
    Member
    Posted 7 years ago #

    the "details of extensions to load and directory info" I was talking about were values in the wp_options table in your database that could cause wp-admin to mess up, but these values would be reset to acceptable values on a clean install.

    Only other trouble I can think of is an errant .htaccess file that is confusing WP.

    If the rest of the site is working, and you have the proper set of files with a fresh install of the DB, there is nothing else that should cause wp-admin to fail.

  5. austinc
    Member
    Posted 7 years ago #

    The following is all that is in the .htaccess file:

    php_value display_errors "0"
    php_value log_errors "1"
    php_value error_log "/var/www/logs/php.err"
    php_value error_reporting 2047

  6. geoffe
    Member
    Posted 7 years ago #

    strange content out of your rss feed too:
    http://www.earthsky.org/blog/?feed=rss2

    It's starting with that <?xml version="1.0" encoding="us-ascii" ?> which shouldn't be there.

    Where is that htaccess file located, in the root directory? And where are these related threads?

    To add to the confusion, I don't find the text us-ascii anywhere in WordPress' code, so I'm not sure where that would be coming from.

  7. austinc
    Member
    Posted 7 years ago #

    The htaccess file is located /var/www/earthsky/, which is one level before the blog folder and all of the html/php pages.

    I'm not sure about the us-ascii. Do you think it might have something to do with the Apache configuration?

    Thanks for your time in looking in to this Geoff. Let me know if you think of anything else.

  8. geoffe
    Member
    Posted 7 years ago #

    I don't believe that WordPress is generating the <?xml version="1.0" encoding="us-ascii" ?> line for you, or I'd check what version of WP you are installing because I don't find any evidence of it being generated by WordPress in any of its files.

    Have you tried removing the htaccess file and seeing how it works? I'd have to think that apache is the monkey wrench to what WP wants to do, and somehow those error reporting settings could cause it? I don't know..

    Ah, I'm just cluing into the fact that every page on your server is beginning with the line <?xml version="1.0" encoding="us-ascii" ?> so there you go. Somewhere Apache is configured to serve that at the top of every page it sends. You've got to kill that.

    Search your httpd.conf for it.

  9. austinc
    Member
    Posted 7 years ago #

    No luck with the httpd.conf file. I did search/find on all key words, us-ascii, encoding and xml, but I couldn't find anything. Have any other suggestions? I can post the httpd.conf file here if you think it would help.

    I'm about to the point were I should figure a work around. Do you know if there is any way that I can set up the blog at a different host but have the domain be something like blog.earthsky.org. Any suggestions would be helpful.

  10. geoffe
    Member
    Posted 7 years ago #

    Perhaps there's some good reason why every page your server sends begins with <?xml version="1.0" encoding="us-ascii" ?> invariably. I'm not familiar with what the reason is, but I'm confident that's what is breaking WP for you.

    My one thought is to find a forum for webserver help. There's many people out there who might know why your server wants to send everything as an xml file, but this isn't the place to expect to find one.

    And setting up a subdomain on a different server would be tricky. I'm not sure you can or that it would be practical. You could of course just redirect or create a portal using a html page with frames. But to set your server to virtual host a site on another server? If it can be done I'd like to know how. I don't think you can even pay for a domain registration on just a subdomain to give it a fresh nameserver. However, you could just register earthskyblog.org and you're done.

  11. austinc
    Member
    Posted 7 years ago #

    Thanks for your help. I'll look around for a webserver form. I'll let you know if I find out anything.

  12. kih305
    Member
    Posted 7 years ago #

    I'm having the same problem, so please post anything you find.

Topic Closed

This topic has been closed to new replies.

About this Topic