WordPress.org

Ready to get started?Download WordPress

Forums

blank wp-admin page (14 posts)

  1. flyingpenguin
    Member
    Posted 8 years ago #

    Just did the WP2.0 upgrade. Now when I hit http://domain/blog/wp-admin I get a completely blank page. I can go to /wp-admin/edit.php or any of the other pages ok, just not the default page. I even tried setting up a completely vanilla WP2 install where I just copied over my old wp-config.php, and used the default theme with it, but still no admin page. Anything else to try?

  2. brianchurch
    Member
    Posted 8 years ago #

    I'm receiving the same error. All blog pages are blank after trying to upgrade to WP2.0.

    Please Help!

  3. mattman
    Member
    Posted 8 years ago #

    This may be a problem caused by a plugin that is not up to date with 2.0 causing an error.

    Did you de-activate your plugins before hand?

  4. flyingpenguin
    Member
    Posted 8 years ago #

    Yes. All plugins were deactivated. Plus there are no plugins even in the directory now other than the defaults in the WP2 vanilla install.

    Both the "dashboard" (index.php) and the import.php are blank, but all other wp-admin pages work if I hit them directly...

    # Write
    # Manage
    # Links
    # Presentation
    # Plugins
    # Users
    # Options

  5. gashu
    Member
    Posted 8 years ago #

    hi,

    Same here. I am a newbie to WP and did completely vanilla set up. Now I see blank /wp-admin(index.php) etc. but I can use edit.php (so I can post).

    I suspect apache configuration by network provider though.

  6. flyingpenguin
    Member
    Posted 8 years ago #

    Incidentally, I also noticed the database was starting to really grind to a standstill, especially with category queries, so I just did a quick table repair (http://www.tamba2.org.uk/wordpress/repair/) and everything is running smoothly again. Still no admin dashboard, though.

  7. flyingpenguin
    Member
    Posted 8 years ago #

    "apache configuration"

    Aha, excellent point. I'll see what I can find...I'm running apache2 and therefore have been trying to use their newer mod_rewrite stuff instead of the .htaccess file. Likely to be related.

  8. flyingpenguin
    Member
    Posted 8 years ago #

    I've fiddled a bit with the mod_rewrite, but still having issues. Basically I just created a new file here:
    /etc/apache2/conf.d/wordpress.conf

    I added the WP2 permalink suggestions and it breaks the site. It didn't cause any issues under WP1.5 so I'm guessing the new rule syntax is hosed. For date and name based, this is the WP2 suggestion (a directory is required for the server to read without error):

    <IfModule mod_rewrite.c>
    <Directory /path/to/new/wordpress/install>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php
    </Directory>
    </IfModule>

  9. gashu
    Member
    Posted 8 years ago #

    Looks like blank dashboard issue is FAQ.
    http://wordpress.org/support/topic/36254?replies=9
    http://wordpress.org/support/topic/36092?replies=80

    In my case, rss-functions.php is not working probably due to my host. So I got dashboard replacement from Simple Thoughts,
    http://blog.taragana.com/index.php/archive/wordpress-15-hack-how-to-trim-the-fat-resource-hogging-admin-dashboard-version-2/
    and disabled rss-functions.php in line 13 of that index.php.
    #require_once (ABSPATH . WPINC . '/rss-functions.php');

    It is pretty simple but at least I don't see blank dashboard now.

    Hope this will help.

  10. flyingpenguin
    Member
    Posted 8 years ago #

    Interesting, I dropped in the replacement wp-admin/index.html that you suggested, edited out the line you suggested, and the page now loads. Guess I can put the mod_rewrite back now. On to figuring out the import page...

    Thanks!

  11. flyingpenguin
    Member
    Posted 8 years ago #

    Incidentally, I've also found that I get a memory error from the write/edit page with WP2. I was running fine in 8MB (the php.ini default amount) with WP1.5, but the server starting complaining after the upgrade:

    Fatal error: Allowed memory size of 8388608 bytes exhausted

    I had to change memory_limit to 10M...

  12. ooglaser
    Member
    Posted 8 years ago #

    Incidentally, I've also found that I get a memory error from the write/edit page with WP2. I was running fine in 8MB (the php.ini default amount) with WP1.5, but the server starting complaining after the upgrade:

    Fatal error: Allowed memory size of 8388608 bytes exhausted

    I had to change memory_limit to 10M...

  13. wdekreij
    Member
    Posted 8 years ago #

    This may be a problem caused by a plugin that is not up to date with 2.0 causing an error.

    Did you de-activate your plugins before hand?

  14. flyingpenguin
    Member
    Posted 8 years ago #

    Thought I should mention that the 2.0.3 upgrade still has the same issue. I just replaced the wp-admin/index.php page with a simpler non-feed version to fix it again.

Topic Closed

This topic has been closed to new replies.

About this Topic