WordPress.org

Ready to get started?Download WordPress

Forums

Blank screen ufter upgrading to 2.9 (21 posts)

  1. claud925
    Member
    Posted 4 years ago #

    I just upgraded to wordpress 2.9. The auto way. But now my blog doesnt show, neither my admin panel.

    Dont know what to do! Im gonna try to delete plugins from my plugin folder.

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Try renaming the plugins folder first. And renaming your current theme's folder.

  3. claud925
    Member
    Posted 4 years ago #

    I downgraded to wordpress 2.8.6 again. im not planning to upgrade it to 2.9

  4. glenara
    Member
    Posted 4 years ago #

    This is obviously just another ongoing unresolved issue that keeps coming up.

    I found this solution buried in a forum post from some time ago and it worked for me. If you dig deep enough and long enough you may find the original post.

    Plugin Name: Disable Canonical URL Redirection
    Create a file with the name "disable-canonical-redirects.phps"
    Copy the code into it:

    <?php
    /*
    Plugin Name: Disable Canonical URL Redirection
    Description: Disables the "Canonical URL Redirect" features of WordPress 2.3 and above.
    Version: 1.0
    Author: Mark Jaquith
    Author URI: http://markjaquith.com/
    */
    remove_filter('template_redirect', 'redirect_canonical');
    ?>

    Place the file in the plugins directory and activate it in the admin section of the plugins.

    I don't think this plugin is even listed in the plugins or talked about in any help catagories.

    I needed it for both 2.8.6 and again with 2.9
    Probably would fix issues with previous versions as well but the first one I ever installed was 2.8.6.

    Regards.

  5. glenara
    Member
    Posted 4 years ago #

    I made a typo in the name of the file in my previous post.
    It should be named: "disable-canonical-redirects.php"
    (remove the "s" from .phps)

    Regards

  6. glenara
    Member
    Posted 4 years ago #


  7. claud925
    Member
    Posted 4 years ago #

    So... I should make the plugin and activate it before upgrading to 2.9 right?

    Cause after upgrading I wont be able to access the wp-admin

  8. Matt Rude
    Member
    Posted 4 years ago #

    You *should* be able to just add
    remove_filter('template_redirect', 'redirect_canonical');
    to your themes "function.php" file with out needing to downgrade to 2.8.6 in order to activate the new plugin, just to reupgrade to 2.9.

  9. pking123
    Member
    Posted 4 years ago #

    I am getting the same problem from a fresh install of 2.9 (not an upgrade). It can't write wp-config.php (so I paste it in thru an ssh connection), then hit "Run the install", to be confronted by a blank screen.

  10. briant2001
    Member
    Posted 4 years ago #

    problem is when i create the file mentioned above - I can't find anywhere to activate the plugin - still getting blank for everything (auto-upgrade)

    Any ideas where to activate using cpanel backend?

  11. briant2001
    Member
    Posted 4 years ago #

    funny thing - all I did was rename plugins folder, refresh site - it worked with NO plugins (obviously) then I changed folder back to "plugins" - all seems to be fin - not sure which plugin is the issue though!

  12. Cenay
    Member
    Posted 4 years ago #

    Chased the bug round and round for several hours. After I found the solution, I tested it out on 14 blogs having the same problem. Worked like a charm on 12 of the 14. The other two required upgrades to the plugins before the problem went away..... so start here...

    http://www.cenaynailor.com/blogging/wordpress-blogging/fix-the-wordpress-blank-page-error/

    Basically, it boils down to certain of your key files in the WordPress set having a blank line after the closing PHP tag. ( ?> )

    By opening wp-settings.php and wp-config.php and a couple of others, I was able to remove the blank line and log right in. I know, sounds crazy, but like I said, worked 12 out of 14 times.

    You can do the editing with your control panel file manager, an external FTP client or if you are smart... download WordPress to your local machine first, make the changes, then upload to your domain.

    I will be doing this to all future versions of WP, just to eliminate the possibility. I love WordPress, but do hate the upgrade issues that are pretty regular.

  13. moongoose
    Member
    Posted 4 years ago #

    A good place to start is by viewing the page source on the blank page. It will usually indicate which file is the problem.

  14. chacko
    Member
    Posted 4 years ago #

    Did everything this thread expected me to do. Its still down. lease visit my site and advice.

  15. chacko
    Member
    Posted 4 years ago #

    Solved. I wrote to my server providers. They solved it. But did not tell how.

  16. rainer23
    Member
    Posted 4 years ago #

    I had this also, after upgrading the server's cache memory to 64 MB the problem was gone.

  17. cymbals
    Member
    Posted 4 years ago #

    I had the same problem after the upgrade to 2.9.1 hung. Fixed it pretty easily, thanks to others who had the same problem. I downloaded 2.9.1 to my computer, and then deleted wp-admin and wp-includes on the server. I uploaded the root files and the wp-admin and wp-includes folder. After that it worked. I also could go into the control panel. It warned me that the database needed updating, and that worked quickly without issues. Thanks!

  18. joaociocca
    Member
    Posted 4 years ago #

    this helped... but not much.

    at first, I was getting this error:
    Warning: Cannot modify header information - headers already sent by (output started at /public_html/index.php:1) in /public_html/wp-includes/pluggable.php on line 868

    which contains this:
    header("Location: $location", true, $status);

    after using the mentioned plugin to disable redirects, now I'm getting this other header error:
    Warning: Cannot modify header information - headers already sent by (output started at /public_html/index.php:1) in /public_html/wp-includes/feed-rss2.php on line 8

    which contains this:
    header('Content-Type: ' . feed_content_type('rss-http') . '; charset=' . get_option('blog_charset'), true);

    any ideas, besides the downgrade?

  19. esmi
    Forum Moderator
    Posted 4 years ago #

  20. joaociocca
    Member
    Posted 4 years ago #

    From your link Esmi: "Also check the encoding of the file. If the file is encoded as UTF-8 with BOM, the BOM is seen as a character which starts the output." - and guess who had an index.php saved with UTF-8 with BOM?

    removed it and my rss came back like a charm. thanks a lot! =D

  21. Nikole Gipps
    Member
    Posted 4 years ago #

    Mine was a missing htaccess file. I had published a new page and all the pages went blank ... turns out my htaccess file somehow disappeared. (Viewing source doesn't do anything in this case - the "source" is just a blank page too.)

    I went into Settings > Permalinks, resaved those settings, and the problem was solved.

    My clue in it being higher up than the theme level is that 1) the page came back blank very fast - no load time, and 2) I switched to the default theme and had the same problem.

Topic Closed

This topic has been closed to new replies.

About this Topic