WordPress.org

Ready to get started?Download WordPress

Forums

Blank Screen on WordPress 2.1 Upgrade (28 posts)

  1. GlobalGame
    Member
    Posted 7 years ago #

    Twice I have followed, to the letter, the upgrade instructions for WordPress 2.1, and each time I end up with a blank screen on running the upgrade.php file. Everything is blank, zilch. I can reinstall my old version (2.04), but it is perplexing.

  2. Birger_Nord
    Member
    Posted 7 years ago #

    The smae accour it my site too.

    Nothing is beeing displayed at the wp-admin/upgrade.php.

  3. Lorelle
    Member
    Posted 7 years ago #

    Did you delete all the core WordPress files before uploading them?

  4. Samuel B
    moderator
    Posted 7 years ago #

    This could also be a sign of low php memory. Ask your host to bump it from 4M to 16M or 20M. Should work.

  5. Birger_Nord
    Member
    Posted 7 years ago #

    I use (mt) Media Temple's (gs) Grid-Server. You should think that they would work out fine.

  6. Ajd777
    Member
    Posted 7 years ago #

    No php memory is defined in the php.ini file; you could be on the worlds best server, but it doesn't matter unless you specifically bump it up.

  7. Birger_Nord
    Member
    Posted 7 years ago #

    Isn't there any possibilities to run a query code inside the database it self? So that you don't need to run the upgrade.php file.

  8. GlobalGame
    Member
    Posted 7 years ago #

    Well, I've done the 2.1 upgrade for the third time, again following all instructions. Same blankness. I'm too tired to restore the old version.

    All core WordPress files were deleted before upload. I've never had any problem with PHP memory before, and Yahoo! Small Business web hosting never replies to support questions. Nor do they supply automatic upgrades, as advertised.

    Anyone can check the site if they like: http://www.theglobalgame.com/blog.

    Thanks for any advice.

  9. metalmd
    Member
    Posted 7 years ago #

    I just contacted my webhoster, and they tell me my php memory was set at 32M.

    Any other suggestions?

  10. GlobalGame
    Member
    Posted 7 years ago #

    Finally resolved the difficulties. Hallelujah. I reinstalled MyPhpAdmin and updated MySQL user name and password in config.php file in WordPress root directory. for whatever reason, this worked.

    Thanks for the helpful comments.

  11. metalmd
    Member
    Posted 7 years ago #

    I don't understand what you did. You reinstalled your PhpAdmin?

    Then you updated your MySQL user name and password. Do you mean you changed your user name and password? or just reinstalled your phpConfig file?

    Hopefully you're still there, or someone else can explain what GlobalGame did.

  12. GlobalGame
    Member
    Posted 7 years ago #

    I reinstalled phpMyAdmin. I changed the password in MySQL. I updated the config.php file with the new information and replaced the old config.php with the new one. This did the trick.

  13. metalmd
    Member
    Posted 7 years ago #

    Ok, I understand the part about changing the password in MySQL, that was easy, but... and I hate sounding stupid, how did you reinstall your phpMyAdmin?

  14. GlobalGame
    Member
    Posted 7 years ago #

    I'm not sure if this was the critical part of the correction, but I deleted all phpMyAdmin files via an FTP utility. It's exactly the same procedure as purging files before uploading the WordPress 2.1 upgrade files.

    Once the phpMyAdmin folder was empty, I uploaded the backed-up files.

    I think the critical part in the procedure was making sure the config.php information was accurate: user name, password, and so on.

    But who knows?

  15. Dickie
    Member
    Posted 7 years ago #

    I don't know if this is what some people are seeing, but before 2.1 was released a had a go here with the Release candidates to check my site for compatibility.
    I had exactly this problem. Blank pages with no content.
    To cut a long story short I traced it down to some whitespace after the php tags in my theme's functions.php file.

    I don't know if the order of include has changed in 2.1 so that content trying to be sent before headers are sent has now moved to the theme, but this fixed it.

    It didn't seem to cause a problem in 2.0.x

    Have a look at ALL your theme files, and make sure that there is NO whitespace both before the <?php AND after the ?>

  16. metalmd
    Member
    Posted 7 years ago #

    Well I tried deleting everything again, and reinstalling v2.1 and everything is working fine.

    Obviously I did something wrong the first time. Just don't know what it was.

  17. Ololade
    Member
    Posted 7 years ago #

    i'm having the same problem...

    'not sure I understand anything anyone has said in this forum...

    I'm running the blog on yahoo small business web hosting... does any kind soul want to help me fix this? (dumb it down as much as possible)

    The blog is for a non-profit and though it hasn't officially been launched yet, people will need to begin posting on it soon...I hope this can be resolved before then :(

    any kind souls out there??

  18. metalmd
    Member
    Posted 7 years ago #

    Just be sure to deactivate all your plugins, and delete all the old files from the previous version of WordPress that you are using, with the exception of your wp-contents folder and your wp-config.php file.
    (Ref: http://codex.wordpress.org/Upgrading_WordPress#Step_7:_Delete_the_old_WordPress_files)

    I'm sure the reason it didn't work the first time for me, was I must not have deleted something that should have been deleted

  19. Birger_Nord
    Member
    Posted 7 years ago #

    I did not disable the plugins. But I can image that is the reason for the upgrade.php not to display.

  20. Tdude
    Member
    Posted 7 years ago #

    Hej Birger and others!
    Here is a noob solution that you could try:
    I got the same blank screen after activating the Hemingway theme after a clean and functioning 2.1 install on an IIS server (doesn't show php error msgs). Just rename your theme folder and your installation should go back to the default theme. Try another theme until there's a fix.
    Hemingway seems to have some issues with php5.

  21. Ololade
    Member
    Posted 7 years ago #

    I've deleted/re-installed 4 times... what could possibly be the problem? I've done everything to the letter... (???)

  22. Dickie
    Member
    Posted 7 years ago #

    Did you look at all your theme's functions.php file to see if there is any whitespace before or after the php tags?

  23. Birger_Nord
    Member
    Posted 7 years ago #

    I fixed it. I just renamed the plugin folder, and uploaded all the files as a new copy. Then I upgraded, and deleted the new plugin folder after. Last I renamed the old plugins folder back. And all done!

  24. thetoddblog
    Member
    Posted 7 years ago #

    I'm having the same issue.

    I'm on the Yahoo! Small business server too. Would there be some issue with our database not connecting to the new installation?

    Yahoo! support is useless on this matter - they're blaming it on WordPress and recommend automatically upgrading, which Yahoo! rarely, if ever does.

  25. thetoddblog
    Member
    Posted 7 years ago #

    All right, for those on Yahoo! i did something that worked for me.

    1. Do everything that the instructions say.
    2. Delete the wp-config.php file off of your server (make sure you have a backup on your computer somewhere)
    3. Run the upgrade script
    4. When you get the WordPress error message, click the link at the end of the sentence (the last thing you can click, I'm not sure what it says exactly)
    5. Enter your correct information.
    6. Have fun!
    7. If you still get some errors, download your newly configured wp-config file and compare it to your old, make the necessary changes to your old wp-config.php file and upload it, overwriting the existing one.

    I hope that works for you!

  26. ElTorqiro
    Member
    Posted 7 years ago #

    I had the same symptoms as the original poster. After following the install instructions, the wp-admin/upgrade.php returned a blank page (completely empty content, not just a blank HTML page). All other pages returned the same.

    My problem was caused by missing files. Even though I had selected all WordPress files in FileZilla and they had all been processed and marked as successful by the queue, for some reason a heap of files were missing. Unfortunately, in /wp-settings.php there are a *heap* of require() functions which do not report anything if they fail - they just terminate the script. Hence the blank pages if anything that is required()'d is missing. In my case, I found this by debugging until I found where the script was terminating and it was on the wp-includes/default-filters.php require().

    After I re-uploaded all the files and babysat the upload process to make sure there were no hiccups it all went through properly and the site is running properly now.

    So, if you have the blank page problem I'd suggest checking your uploads, even if your FTP client has reported success on each file.

    For the developers, I realise it might be inefficient and a hassle to maintain, but perhaps in the /wp-admin/upgrade.php file you could do a file-existence check for all the files that are supposed to exist in the WP package before doing any other code. Or provide another complete file (e.g. /wp-admin/checkfiles.php) that would not do an include on /wp-config.php or anything else but just do a bunch of file-existence checks to confirm the files exist and are the right size. Then we could run that. You could probably write something small at your end to automatically create such a php file each time a new release is pushed out based on the package contents. I've written a util at my end that does this for me now, if you want it I can send it on. Contact me at my registered address here.

    Cheers!

  27. sagetips
    Member
    Posted 7 years ago #

    For what it's worth to anyone, I had the "blank screen at login" problem after installing the Silver Lexus theme and activating the In-series plugin. Deactivating the plugin solved it for me.

  28. itsvery
    Member
    Posted 7 years ago #

    i had the same problem (not with upgrade, but clean install).

    the problem was solved by removing a line-break in the file functions.php in the wp-includes folder.
    it was after the closing ?> tag. when i removed it the installation worked perfectly fine!

Topic Closed

This topic has been closed to new replies.

About this Topic