WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blank Permalink Settings (11 posts)

  1. matthewhunter
    Member
    Posted 4 years ago #

    I have recently installed wordpress on a subdomain of my website and everything seems to be fine except for the fact that the permalink settings page is blank after the header.

    Screen Shot:

    http://img706.imageshack.us/img706/7929/captureyzn.jpg

    I am not sure what the issue is, please help.

  2. wphelpcenter
    Member
    Posted 4 years ago #

    Are you noticing this on any other admin pages or only the permalinks page?

  3. matthewhunter
    Member
    Posted 4 years ago #

    Only on the permalinks page.

  4. phr3ak
    Member
    Posted 4 years ago #

    see your security settings. i think apache_get_modules function is disabled in your php.

  5. Jauhari
    Member
    Posted 4 years ago #

    How to check apache_get_modules disabled or not? and how to fix it?

  6. Tfleming
    Member
    Posted 4 years ago #

    Jauhari -- did you ever get this resolved? If so, what was the solution?

    Tony

  7. redsuperhawk
    Member
    Posted 4 years ago #

    Has there ever been a resolution to this problem? I'm running into the same problem.

    I'm on a Mac OS X 10.5.8. Firefox browser. Also having the problem on Media > Add New page, and when I have the WP e-commerce cart plugin I have a similar problem on the Store > Products page.

    The weird part is that on a PC (XP, Firefox and IE) the only page having this problem is the Permalinks page.

    Thank you,
    Jeff

  8. Mariokluser
    Member
    Posted 4 years ago #

    I just see that I have this problem (in Google Chrome) after I made a clean installation of 2.9.2 and upgrade it to 3.0

    My Firefox browser can't display my site at all btw. but this is another story.

  9. Mariokluser
    Member
    Posted 4 years ago #

    For me it's the installation of my hosting account. Everything works well on my other domain.

  10. bellafaith
    Member
    Posted 4 years ago #

    I just did a new installation of 3.0.1 and was having the same issue. I found this post, which basically says to comment out the following groups of code in wp-admin/options-permalink.php:

    Around line 92:

    if ( ! got_mod_rewrite() && ! $iis7_permalinks )
    	$prefix = '/index.php';

    Around line 153:
    $wp_rewrite->flush_rules();

    It worked for me!

  11. Vijay Padiyar
    Member
    Posted 3 years ago #

    Hi bellafaith and others

    Instead of all this, why not tackle the root of the problem. The core issue is incompatibility between WordPress 3.0.1 and latest PHP versions.

    Zeniph's solution given here solves the problem.

    You basically need to change the function got_mod_rewrite() in wp-admin/includes/misc.php to the following:

    function got_mod_rewrite() {
    	//$got_rewrite = apache_mod_loaded('mod_rewrite', true); //old line with false negative;
    	$got_rewrite = true;//force the response to true as we know mod_rewite is installed;
    	return apply_filters('got_rewrite', $got_rewrite);
    }

    Regards

    Vijay Padiyar

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags