WordPress.org

Ready to get started?Download WordPress

Forums

Blank Pages (whole site and admin) after upgrade to PHP 4.4.2 (7 posts)

  1. Eric Marden
    Member
    Posted 7 years ago #

    I've searched the forums, and tried some of the things others have done to fix the blank pages issue. Last night my host upgraded from PHP 4.4.0 to 4.4.2. This is a dedicated server, and it was at my request (SugarCRM was needed on another site and required the upgrade). Upgrade went fine, and all of my sites and apps are working - except two of them that are of course running WordPress. Both sites were fine before the upgrade, and now all the pages, including the admin pages are coming up blank.

    Here's some relevant info about my environment:

    PHP Version 4.4.2
    Command './configure' '--host=i686-redhat-linux-gnu' '--build=i686-redhat-linux-gnu' '--target=i386-redhat-linux-gnu' '--program-prefix=' '--prefix=/usr' '--exec-prefix=/usr' '--bindir=/usr/bin' '--sbindir=/usr/sbin' '--sysconfdir=/etc' '--datadir=/usr/share' '--includedir=/usr/include' '--libdir=/usr/lib' '--libexecdir=/usr/libexec' '--localstatedir=/var' '--sharedstatedir=/usr/com' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--cache-file=../config.cache' '--with-config-file-path=/etc' '--with-config-file-scan-dir=/etc/php.d' '--enable-force-cgi-redirect' '--disable-debug' '--enable-pic' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-db4=/usr' '--with-curl' '--with-exec-dir=/usr/bin' '--with-freetype-dir=/usr' '--with-png-dir=/usr' '--with-gd' '--enable-gd-native-ttf' '--without-gdbm' '--with-gettext' '--with-ncurses' '--with-gmp' '--with-iconv' '--with-jpeg-dir=/usr' '--with-openssl' '--with-png' '--with-pspell' '--with-regex=system' '--with-xml' '--with-expat-dir=/usr' '--with-dom=shared,/usr' '--with-dom-xslt=/usr' '--with-dom-exslt=/usr' '--with-xmlrpc=shared' '--with-zlib' '--with-layout=GNU' '--enable-bcmath' '--enable-exif' '--enable-ftp' '--enable-magic-quotes' '--enable-safe-mode' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--enable-yp' '--enable-wddx' '--with-pear=/usr/share/pear' '--with-imap=shared' '--with-imap-ssl' '--with-kerberos=/usr/kerberos' '--with-ldap=shared' '--with-mysql=shared,/usr' '--with-mhash=shared' '--with-mcrypt=shared' '--enable-xslt=shared' '--with-xslt-sablot' '--with-sablot-js=/usr' '--with-pgsql=shared' '--with-snmp=shared,/usr' '--with-snmp=shared' '--enable-ucd-snmp-hack' '--with-unixODBC=shared,/usr' '--enable-memory-limit' '--enable-bcmath' '--enable-shmop' '--enable-calendar' '--enable-dbx' '--enable-dio' '--enable-mcal' '--enable-mbstring=shared' '--enable-mbstr-enc-trans' '--enable-mbregex' '--with-apxs2=/usr/sbin/apxs'

    Apache 2.0.46

    Loaded Modules:
    core prefork http_core mod_so mod_access mod_auth mod_auth_anon mod_auth_dbm mod_auth_digest mod_include mod_log_config mod_env mod_cern_meta mod_expires mod_deflate mod_headers mod_usertrack mod_unique_id mod_setenvif mod_mime mod_dav mod_status mod_autoindex mod_asis mod_info mod_dav_fs mod_vhost_alias mod_negotiation mod_dir mod_imap mod_actions mod_speling mod_userdir mod_alias mod_rewrite mod_proxy proxy_ftp proxy_http proxy_connect mod_cache mod_suexec mod_disk_cache mod_file_cache mod_mem_cache mod_cgi mod_webapp mod_fpcgid mod_auth_mysql mod_auth_pgsql mod_authz_ldap mod_perl sapi_apache2 mod_python mod_ssl

    (note mod_rewrite is enabled and loaded)

    Red Hat Entrprise 3

    MySQL 4.1.12

    As far as I can tell nothing changed except the PHP version. I host at rackspace and have them looking into it. But wanted to throw it out to the WP community and see if anyone's run into this before. The other blank page posts in the forums didn't reveal much info. I have shell access to the server, so there's not much I can't do or have done to help debug this issue.

    Thanks for all your help in advance!

  2. Eric Marden
    Member
    Posted 7 years ago #

    When a request to a WordPress page is made it actually causes the apache child process to segfault, which is why a blank page is returned. I would recommend that we go ahead and down grade to PHP 4.4.0 to ensure this isn't an issue with this particular PHP build.

    This is what Rackspace has found out so far. I'll let you know if we find a solution.

  3. Eric Marden
    Member
    Posted 7 years ago #

    Now rackspace is saying that WordPress has problems with PHP 4.4.2 - can anyone confirm that?

  4. genshi
    Member
    Posted 7 years ago #

    Same exact thing is happening with my host Javapipe. They can't figure out why this is happening but they did upgrade to 4.4.1 (as well as to a new server os called CentOS or something like that. My wordpress site is completely down now and I am getting no help anywhere!

    (posted my support request on here yesterday with no replies...)

  5. Eric Marden
    Member
    Posted 7 years ago #

    Rolled back to PHP 4.4.0 - All is well and wordpress is back up. And because SugarCRM 4.2 was installed while in 4.4.2 (the install would stop because 4.4.0 is an unsupported version), it is still running and is functional. It could blow up, but we'll see.

    Just wanted to update the thread for the next blank pages searcher.

  6. Womensmedia
    Member
    Posted 7 years ago #

    Having same problem. Any idea on a fix?

  7. luchtzak
    Member
    Posted 7 years ago #

    Same problem here, is there a way to get it fixed? my website is http://www.bartenemmy.be totally not working anymore: PHP 4.4.2 WP 2.0.2

    please WP-community, help us out on this matter!

Topic Closed

This topic has been closed to new replies.

About this Topic