WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Blank Pages, tried everything I know (5 posts)

  1. WiBu
    Member
    Posted 7 years ago #

    I was playing around with my wordpress install at http://www.errr.com and I decided to clear WP-Cache's cache to make sure a change to the index template went into effect immeditely.

    So I proceeded to press the clear cache and all of my non-admin pages now don't render, the lovable blank pages of doom.

    I've tried everything I can think of, turning off plug-ins, deleting plug-ins, checking wp-config for blank spaces, replacing all of wordpress' files but nothing seems to have worked; I've even tried rebooting the server (it's a VPS).

    Anyone have any idea? It's running wordpress 2.1 and the admin is fully functioning, the rss feed is too.

  2. PeterUpfold
    Member
    Posted 7 years ago #

    Is there anything in your web server logs that might help? Can you check the error log?

  3. WiBu
    Member
    Posted 7 years ago #

    I've "found" the solution. I uploaded the default theme, chose it, then switched back to my theme. Seems to be working fine now.

  4. Tdude
    Member
    Posted 7 years ago #

    Hi!
    I'm running WP on a IIS (Microsoft), I get blank pages all the time when hacking the files, because of server/php settings or something.
    I don't know exactly what the clear cache would do to your files, but try backstepping any code changes you might have made to the other files. If that doesn't work, switch to the default template after turning off the plug-ins. After that, try erasing the relevant server files and finally make a clean reboot after backing up your db.
    If you have recently upgraded to WP 2.1, maybe some files were left on the server?
    I'm no expert. Just trying to lend a hand ;)
    /T

  5. WiBu
    Member
    Posted 7 years ago #

    "If you have recently upgraded to WP 2.1, maybe some files were left on the server?"

    I upgraded to 2.1 the day it was released.

    Anyway, I'd already followed most of your tips to no avail but it's all sorted now as I said in the post above yours...

    "I uploaded the default theme, chose it, then switched back to my theme. Seems to be working fine now."

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.